• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Unable to Moderate as Administrator

#1
I am thoroughly confused at this point.

The account I created when I installed xenForo (B6) does not seem to have the permission to do anything, other than post and, of course, access Admin Console and perform all admin functions in there. I have made it a moderator....so it is Super Admin, Admin, Super Mod, yet, I cannot edit any post other than my own, nor delete any other.

I see the Moderated Posts = 0 in upper left, but I had a post in moderation, and could not see it with the SAdm, Adm, SMod account, nor any thread tools (sticky, delete, etc...).

What the hay am I doing wrong here?

Tired...need sleep. Need help more...

Ugh,

The Possum
 

Jake Bunce

XenForo moderator
Staff member
#2
Mod permissions can be granted with group or individual permissions. Try adding the moderator in your:

Admin CP -> Users -> Moderators -> Create New Moderator

Screen shot 2011-01-17 at 1.24.01 AM.png
 
#3
When I go there, it shows my account, BTBAdmin, as a Moderator already.



When click the username in there, BTBAdmin, it shows the following permissions:


I have added, deleted and readded again new users, and made them a moderator, to no avail.

According to this, I should have all permissions to perform moderation tasks on all forums within the board.

Something has me stymied with permissions here, and I do have ALOT of experience (8+ years) in board administration on various platforms. This is the first time, ever, I have been unable to figure this out. I know we'll get it solved, but for now it is driving me batty.

Thanks!
 

Brogan

XenForo moderator
Staff member
#4
Are you a member of any secondary groups and are any permissions set to Deny in those groups?

Deny overrides Allow.
 
#5
Brogan,

BTBAdmin is a member of Administrators & Moderators. Both groups have ALLOW for all, with nothing set to DENY.

There are no custom permissions set at any user level.

This is what has me in such a quandary.
 

Brogan

XenForo moderator
Staff member
#8
Just took a quick look.

You have Deny set on some permissions for the Registered Users usergroup and that is one of the Secondary Usergroups you are a member of.

As I said above, a Deny overrides an Allow.

You need to remove those Deny settings or remove yourself from the usergroup.
Permissions are cumulative so just set them to Default for Registered Users.
 
#9
Ugh, thanks. I'll dig into it. I do appreciate your looking at it. New software is always a trick getting used to the intricacies.
 
#10
Got it now, and thanks Brogan. The permissions properties on xenForo are different than anything I have used in the past, but no worries, I think I go tit figured out now.

So, just to make sure I understand properly, One should really leave the permissions set at default for each usergroup, correct?
 
#12
Well, I figured it was something odd like that, but now I GET IT. Between your guidance and the reference thread, I fully understand this now. Thanks again.

The Possum