1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Duplicate Unable to get feeds system to work

Discussion in 'Resolved Bug Reports' started by tmb, Jan 14, 2011.

  1. tmb

    tmb Active Member

    I originally used an upgrade and attempted to get the system to work using known working feeds, had other users do the same configuration I had and it worked for them. I then did a fresh install and the system still doesn't work. Don't want to keep cluttering up the other forum when this may be a bug somewhere.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Can you post the precise details of the problem?
    Are there any error messages, anything in the server log, etc?

    There have been several threads about feeds so it's possible it has already been reported.
  3. tmb

    tmb Active Member

    Ok I am running Linux 64 bit server. I can set up the feed system without any errors and it saves my information just fine. I hit import and have waited for it to post and nothing has posted at all on the forum. I have tried using both guest account and admin account to post from in case of permissions issue.
    It appears in the apache error log this could be the issue?

    Failed loading /usr/local/lib/php/20050922/ZendExtensionManager.so: /usr/local/lib/php/20050922/ZendExtensionManager.so: cannot open shared object file: No such file or directory
  4. Mike

    Mike XenForo Developer Staff Member

    If that error message only appears when you do this, then that's a server configuration error. But I don't really think that's the case.

    What's the feed?
  5. tmb

    tmb Active Member

    I tried ESPN feed, google feed, engadget feed, and the formula 1 bbc feed I saw posted by others that said it worked. I know at least 3 of those feeds have worked for others.
  6. Dav

    Dav Active Member

    Im still having trouble with my feeds. Iv also tried known working feeds that other users have posted and hit import feed and nothing happens.

    I have just bought another license for Xenforo and also started on a new site and i have set up the feeds there and still no luck. When i also click on the orange rss feed buttons in my forum i get this message "An unexpected error occurred. Please try again later." This is a fresh install with no add-ons or template edits as i have only started it today.

  7. Vladislav Rastrusny

    Vladislav Rastrusny Active Member

    I have the same problem. Feed saves all ok but does not get imported into forum. In my case no errors are thrown. Neither in php errors log nor in the forum error log. The feed just silently does not import.

    The forum where I am importing the feeds already have some entries.
  8. Mike

    Mike XenForo Developer Staff Member

    At this point, it's probably best to see what happens with the next release - there are a bunch of fixes to this.
  9. tmb

    tmb Active Member

  10. Mike

    Mike XenForo Developer Staff Member

    I can't reproduce this. Can you turn on debug mode and see if that gives you a better error? Add this to library/config.php:

    $config['debug'] = true;
  11. Mike

    Mike XenForo Developer Staff Member

  12. tmb

    tmb Active Member

    That fix got it working. Thank you so much!

Share This Page