1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Unable to edit some posts

Discussion in 'Troubleshooting and Problems' started by ScottLott, Sep 13, 2013.

  1. ScottLott

    ScottLott Member

    I'm having an issue editing posts on a forum updated to 1.2.1.

    I'm using a local copy of the website on XAMPP to build a new theme and test the update before I make it live on my website.

    Large posts cannot be edited at all. Clicking the "edit" button to bring up the quick editor results in NOTHING coming up on the screen. When I open the edit link in a new tab, the page doesn't load at all.

    The error in both Firefox and Chrome are "The Connection was Reset"

    Chrome:
    Firefox:
    - I can edit small posts without a problem, this only happens with large posts.
    - I AM running 1.2.1 with the regex fix listed in a similar issue I found trying to Google this problem.
    - There are no Admin error logs.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    How large is large?

    You may need to tweak the xampp sql settings.
     
  3. ScottLott

    ScottLott Member

  4. Mike

    Mike XenForo Developer Staff Member

    If you turn off the rich text editor in your options, you should be able to edit the post. You'll see just how many BB codes are in it, which is likely the cause. (This is tweaked for new posts in 1.2 BTW.)

    Can you attach the content of the post in a txt file?
     
  5. ScottLott

    ScottLott Member

    Thanks Mike,
    I tried disabling my BBcode addon to prevent the custom BB codes from parsing. The addon disabled without a hitch, but it didn't effect my ability to edit the posts.

    I've attached a txt file of one of the problem posts.

    Also, disabling the rich text editor did allow me to edit the post.
     

    Attached Files:

    Liam W likes this.
  6. Liam W

    Liam W Well-Known Member

    Looks like @Mike is right with it being something to do with the BBCODE content, there's an awful lot of BBCODE in that post...

    Do you get any PHP errors, on an off chance, in a PHP error log?

    Liam
     
  7. Mike

    Mike XenForo Developer Staff Member

  8. ScottLott

    ScottLott Member

    Perfect. That fixed it. Thanks so much for the help, Mike.
     
  9. ScottLott

    ScottLott Member

    I checked the PHP and Apache error logs and wasn't able to find anything relevant to the post edit issue. I know it's tons of BBcode, we've had the issue since we moved to XenForo. I'm not sure if it's something wer'e doing, but BBCodes don't span multiple lines, instead they are automatically copied to extra lines.

    For example, when we were using vBulletin 4 we could do something like this:
    Code:
    [B]This statement takes up
    multiple lines but the bold
    effect works on all the lines[/B]
    But XenForo (atleast up to v1.13) seemed to take that and automatically turn it into this:
    Code:
    [B]This statement takes up[/B]
    [B]multiple lines but the bold[/B]
    [B]effect works on all the lines[/B]
    I tried to fix it without any success. It didn't seem to effect the way the post was displayed, so I just let it go.

    It's entirely possible that I'm doing things wrong/I missed a setting somewhere, but it's why we've got a crap ton of BB code in those posts.
     
  10. Mike

    Mike XenForo Developer Staff Member

    That behavior has changed in 1.2.
     
    ScottLott likes this.

Share This Page