1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Unable to Connect to tcp://www.gravatar.com:80

Discussion in 'Troubleshooting and Problems' started by JordanH, Feb 22, 2014.

  1. JordanH

    JordanH Well-Known Member

    Hi,

    I keep getting these errors on both my boards
    (one of them is on 1.2, the other one is on 1.3 beta 4)

    Error Info:
    Code:
    Zend_Http_Client_Adapter_Exception: Unable to Connect to tcp://www.gravatar.com:80. Error #0: php_network_getaddresses: getaddrinfo failed: Name or service not known - library/Zend/Http/Client/Adapter/Socket.php:235
    Generated By: Unknown Account, 5 minutes ago
    Stack Trace:
    Code:
    #0 /home/offtopic/public_html/library/Zend/Http/Client.php(973): Zend_Http_Client_Adapter_Socket->connect('www.gravatar.co...', 80, false)
    #1 /home/offtopic/public_html/library/XenForo/Model/Avatar.php(457): Zend_Http_Client->request('HEAD')
    #2 /home/offtopic/public_html/library/XenForo/ControllerPublic/Register.php(219): XenForo_Model_Avatar::gravatarExists('****@****.com')
    #3 /home/offtopic/public_html/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Register->actionRegister()
    #4 /home/offtopic/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #5 /home/offtopic/public_html/index.php(13): XenForo_FrontController->run()
    #6 {main}
    Request State:
    PHP:
    array(3) {
      [
    "url"] => string(42"http://www.offtopicz.com/register/register"
      
    ["_GET"] => array(0) {
      }
      [
    "_POST"] => array(15) {
        [
    "username"] => string(9"****"
        
    ["email"] => string(33"****@****.com"
        
    ["password"] => string(8"********"
        
    ["password_confirm"] => string(8"********"
        
    ["dob_month"] => string(1"3"
        
    ["dob_day"] => string(2"18"
        
    ["dob_year"] => string(4"1981"
        
    ["gender"] => string(4"male"
        
    ["timezone"] => string(16"America/Miquelon"
        
    ["captcha_question_answer"] => string(0""
        
    ["captcha_question_hash"] => string(40"***"
        
    ["agree"] => string(1"1"
        
    ["submit"] => string(7"Sign up"
        
    ["_xfToken"] => string(8"********"
        
    ["reg_key"] => string(32"***"
      
    }
    }
    Anyways that's just one example. There's a BUNCH of them happening from time to time.
     
  2. Sheratan

    Sheratan Well-Known Member

    There is a problem in your server connection to gravatar, or gravatar to your server. This is not xenforo problem.

    -edit-
    Wait. Any chance the person who trying to register email is look-a-like spammer email?
     
  3. JordanH

    JordanH Well-Known Member

    Would not know atm xD I cleared the server log xD

    I will reply next time it happens xD
     
  4. Sheratan

    Sheratan Well-Known Member

  5. SchmitzIT

    SchmitzIT Well-Known Member

    I've been seeing similar errors, though the gravatar one I saw was apparently due to gravatar bieng down. However, I saw the same error with a custom URL we use. I submitted a ticket, and was told it was most likely due to a DNS issue at my end.

    I ended up editing /etc/host and adding the custom URL there, and that solved my issues :)
     
  6. JordanH

    JordanH Well-Known Member

    Never heard the likes of it.
    How do you end up doing custom URLs?
     
  7. JordanH

    JordanH Well-Known Member

    Nope. Got legit users making this happen to...

    Also, seems to not be sending out activation email.
     
  8. SchmitzIT

    SchmitzIT Well-Known Member

    The custom URL was just a sub-domain we created that points to a Google Appserver.
     
  9. NeoCHI

    NeoCHI Active Member

Share This Page