• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Unable to Connect to tcp://www.google.com:80 and tcp://api-verify.recaptcha.net:80

#1
My forum is full of this error logs.
2017-05-15 11_05_43-Server Error Logs _ Admin CP - Olympus Gaming Network.png
I haven't checked the admincp for over 1 month so I cant really say when it started happening.
Any idea what is causing it?
 

Chris D

XenForo developer
Staff member
#2
It's a communication error between your server and the outside world; specifically Google (for sitemap pings) and ReCAPTCHA.

In the first instance, report the issue to your host. They will likely have to do something to unblock those requests.
 

Chris D

XenForo developer
Staff member
#4
Well, they're mentioned in the errors. Port 80. It seems outgoing HTTP connections on your server may be blocked.
 

Chris D

XenForo developer
Staff member
#7
It may not be that exactly, but the issue is effectively happening outside of XenForo's involvement. All we're doing is performing a HTTP request and that is failing. That failure exists between your server and the URL being requested so there is most certainly something blocking it somewhere.
 
#8
My machine IP is also clean and not blacklisted anywere, you are 100% this is not something related to a bad config or anything else?
 

Chris D

XenForo developer
Staff member
#9
Absolutely, there's not really anything to configure here. It should be a fairly simple HTTP request and there shouldn't be many reasons that should fail.

A similar issue was reported here and there was a non-firewall related solution:
https://xenforo.com/community/threa...p-to-google-unable-to-connect-to-tcp-w.92276/

A good diag step as suggested by Mike in that thread is seeing if you can do a wget on that URL from your shell. If it fails, that definitely rules out anything within XF itself.
 
#10
Hmmmm, seems like my machine also has issues connecting to ipv6 address.
The thread mentioned above does not clearly says how he solved the issues so any further assistance is welcomed :d
 
#11
For those who experience this, if your machine has and IPV6 address and you dont really use it, the easiest way to fix the issue is to disable the ipv6.

TY @Chris D for the assistance so far.
 
Last edited: