1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Unable to Connect to api-verify.recaptcha.net

Discussion in 'Troubleshooting and Problems' started by bukoo, Aug 20, 2014.

  1. bukoo

    bukoo New Member

    Zend_Http_Client_Adapter_Exception: Unable to Connect to tcp://api-verify.recaptcha.net:80. Error #0: php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution - library/Zend/Http/Client/Adapter/Socket.php:235


    #0 /home/nginx/domains/bodyforumtr.com/public/library/Zend/Http/Client.php(973): Zend_Http_Client_Adapter_Socket->connect('api-verify.reca...', 80, false)
    #1 /home/nginx/domains/bodyforumtr.com/public/library/Zend/Service/ReCaptcha.php(487): Zend_Http_Client->request('POST')
    #2 /home/nginx/domains/bodyforumtr.com/public/library/Zend/Service/ReCaptcha.php(502): Zend_Service_ReCaptcha->_post('03AHJ_VutizAfE9...', '6106')
    #3 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/Captcha/ReCaptcha.php(53): Zend_Service_ReCaptcha->verify('03AHJ_VutizAfE9...', '6106')
    #4 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/Captcha/Abstract.php(129): XenForo_Captcha_ReCaptcha->isValid(Array)
    #5 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/ControllerPublic/Register.php(200): XenForo_Captcha_Abstract::validateDefault(Object(XenForo_Input))
    #6 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/FrontController.php(337): XenForo_ControllerPublic_Register->actionRegister()
    #7 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #8 /home/nginx/domains/bodyforumtr.com/public/index.php(13): XenForo_FrontController->run()
    #9 {main}


    array(3) {
    ["url"] => string(44) "http://www.bodyforumtr.com/register/register"
    ["_GET"] => array(1) {
    ["/register/register"] => string(0) ""
    }
    ["_POST"] => array(14) {
    ["username"] => string(8) "xxx"
    ["email"] => string(20) "xxx@hotmail.com"
    ["password"] => string(8) "********"
    ["password_confirm"] => string(8) "********"
    ["dob_month"] => string(1) "2"
    ["dob_day"] => string(2) "23"
    ["dob_year"] => string(4) "1994"
    ["gender"] => string(4) "male"
    ["timezone"] => string(13) "Europe/Athens"
    ["recaptcha_challenge_field"] => string(356) "03AHJ_VutizAfE9H4GNHaeoxX5mJWQzGOM7nz1L5VEmVqjZI7uEmbdXXcWggs1EGP8ARgS-UUqIDy8Qg7_d4gYb8J-R5n1OnYdD3aKsG9irAsuZqmHlvtCJYcuWQr5jTp7noszbxN3mp5Ahyt9OzoeDaIypc6kgz_lVKuAQ3r-NSIdZvfZ733M37ZYqiXUb2zSjfksIZ_7w0ObcVGIKo9H_J-LMufJF9NilaupnS7WYMlmvZFwXWxvdJRwcPiiX9_1x_7P6MxR3_oaO15eCRYMWUO_34veqZ5gpK-O2Wl2WqopnH7BaWsKDUd4T9iLGtCNWOz6ZzJMbmVH2PXvbLod_qNugyBK9RAajA"
    ["recaptcha_response_field"] => string(4) "6106"
    ["agree"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["reg_key"] => string(32) "662682506823028343032d482ed317eb"
    }
    }
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It could just be a temporary failure of the recaptcha service.

    If it becomes a permanent failure then it may be a sever configuration issue.
     
  3. bukoo

    bukoo New Member

    Thank you Brogan.
    Yes, I think so that it is a temporary failure, because it seems only some of new users having this trouble.
    Changing recaptcha to "question captcha" may be a solution but if this problem about our server configuration, what can it be and what do i have to change?
     

Share This Page