1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to attach any files

Discussion in 'Troubleshooting and Problems' started by Trekkan, Jan 6, 2012.

  1. Trekkan

    Trekkan Well-Known Member

    I keep getting an error message that simply says "Unable to upload file".

    There are no errors listed in the server error log.

    Filesize doesn't seem to matter, I get the same message whenever it's a 2k file or a 20+meg file.

    File extensions are set in the options (it's a .zip file).

    Server settings show the max file size is 128M.

    I'm stuck, any help would be great, thanks!

    For reference on the error message, it's the same as posted in this thread: http://xenforo.com/community/threads/cant-upload-a-pdf.25578/
     
  2. Shelley

    Shelley Well-Known Member

    I got this error message yesterday and it didn't matter what xenforo forum i tried uploading files to i got the error message with firefox. Have you tried uploading a file using chrome? or another browser. I mentioned the browser issue because the issue you have sounds very similar to what I experienced yesterday.

    it just happened that firefox updated to 9.0.1 when i stopped having the ability to upload files due to a error java console being incompatible.
     
  3. Trekkan

    Trekkan Well-Known Member

    Thanks for the reply Shelly, I'm actually using Chrome however. Also, I have another member that is having the same problem (which is why I started looking into this), but I'm not sure what browser he's using. I'll give FF and IE a shot as well and see what happens.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Has your host made any changes recently?

    The last person to have that issue, it was due to mod security.

    Is it just you and this other member, or everyone?
    If just you two then it's likely to be browser related.
     
  5. Trekkan

    Trekkan Well-Known Member

    Ok, did some uploading in FF, here's the status.

    I was able to upload three files, one was 2K, one 50K and one 3.5M.

    So far, other files at a higher size are failing and I get this popup error in FF after the upload is complete: Error #2044: Unhandled IOErrorEvent:. text=Error #2038: File I/O Error.

    I then tried IE and had the same results as above with FF, using the same files. So there does appear to be some difference when it comes to browsers, but... I dunno.
     
  6. Trekkan

    Trekkan Well-Known Member

    I'm in contact with the host now, they're looking into it. But offhand, no changes were made.

    So far it's just myself and the one member, but we're a really small community and don't have many attachments, so... I'll see if I can have a couple other people upload to test.
     
  7. Trekkan

    Trekkan Well-Known Member

    Ok, still working with the host, but so far no luck and they are having the same problems.

    I can upload an 11meg file fine, but 15+, nope.

    Added the following to the .htaccess but with no luck, same issues.

    I also switched to the standard file upload (turned off the flash uploader) and have the same results. Other than the default basic uploader just acts like nothing happened on the larger files. No error, no nothing.
     
  8. Trekkan

    Trekkan Well-Known Member

    Looks like modsec isn't even installed, which makes sense as to why that change didn't do anything. Host is currently at a loss.
     
  9. Trekkan

    Trekkan Well-Known Member

    Ok, problem solved!

    The host had to set MaxRequestLen in the Apache config to match the php.ini settings, in my case, they are now all set to a value of 128M
     

Share This Page