• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Twitter error on external accounts page

russoroni

Active member
#1
Hello gang, I just upgraded and everything went pretty smooth as far as I can tell with one exception. When I click on external accounts in the personal details page sidebar I get this error:

Server Error
trim() expects parameter 1 to be string, array given

  1. XenForo_Application::handlePhpError()
  2. trim() in Zend/Oauth/Token.php at line 146
  3. Zend_Oauth_Token->setParam() in Zend/Oauth/Token.php at line 187
  4. Zend_Oauth_Token->setToken() in XenForo/Helper/Twitter.php at line 47
  5. XenForo_Helper_Twitter::getService() in XenForo/Helper/Twitter.php at line 72
  6. XenForo_Helper_Twitter::getUserFromToken() in XenForo/ControllerPublic/Account.php at line 1525
  7. XenForo_ControllerPublic_Account->actionExternalAccounts() in XenForo/FrontController.php at line 347
  8. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  9. XenForo_FrontController->run() in /home/trailpeople/public_html/index.php at line 13
 

Mike

XenForo developer
Staff member
#4
Unfortunately, that has likely created incompatible data. The add-on author may have some guidance as to how to resolve it (clearing out the old data may be the main option).
 

Mike

XenForo developer
Staff member
#7
I can have a look via phpMyAdmin if you want me to, to confirm that it is bad data from the add-on. If it is, the only real recommendation from my side would be removing the data (which would require reassociation).