• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Trying to add Google Translation into tab

B

bogus

Guest
#1
Hello . I am trying to implement Googles translation tool into xenforo, very basic.

What i have done till now is, that i´ve added the Code, which can be generated from here into the navigation Template.
before <!-- extra tabs: end -->
add your generated Code, eg.:
Code:
<!-- Google tab: start -->

<div id="google_translate_element"></div><script type="text/javascript">
function googleTranslateElementInit() {
  new google.translate.TranslateElement({
    pageLanguage: 'en',
    multilanguagePage: true,
    gaTrack: true,
    layout: google.translate.TranslateElement.InlineLayout.SIMPLE
  }, 'google_translate_element');
}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>

<!-- Google tab: stop-->
I have added this to the EXTRA.css
Code:
body {top: 0px !important; position: static !important; }
.goog-te-banner-frame {display:none !important}
.goog-te-gadget-simple img {display:none;}//hides the image in the widget
to get rid of the google Toolbar.

Into the PAGE_CONTAINER Template, right before the closing </body> tag
i added
Code:
<style>
.goog-te-gadget-simple {background-color:transparent;border:none;font-size:11px;padding-top:5px;padding-right:40px;}
.goog-te-gadget-simple a:hover {text-decoration: none;}
.goog-te-gadget-simple .goog-te-menu-value {color:#a5cae4;}
</style>
This must be added into the Template itself because the function calls the stylesheet dynamically.

The problem i am running with now are the left border and the Arrow i cant get rid off.
You can see it here working at the Navbar.
Maybe any of you could help me with that.

I have tried to get a pulldown with Flags, but i am not a coder to get jquery implemented.
 
B

bogus

Guest
#2
Thread can be deleted, please. I have solved the "Problem" with a complete different way.