1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Trouble Upgrading from 1.2 RC2 to 1.2

Discussion in 'Installation, Upgrade, and Import Support' started by Tobseb, Jul 30, 2013.

  1. Tobseb

    Tobseb Member

    I just tried to Upgrade from 1.2 RC2 to 1.2. I uploaded all files, and then a message shows up "There are at least 1 file(s) that do not appear to have the expected contents." ... So I got the full package and uploaded everything once again. Same mistake. I didn't know what to do, so I tried to "Begin Upgrade" even if the error was still there. First I got that Error "Line 26: Template syntax error." and afterwards that one "ad_thread_list_below_stickies: Line 1: Template syntax error." (caused by an add-on?).

    I do not really know what I should do now.
  2. Chris D

    Chris D XenForo Developer Staff Member

    Does it still let you into your Admin CP?

    If so, go in, disable all add-ons, and try installing again (after copying the files across for a third time -- also download the package again).

    If you can't get into the Admin CP. Open:


    Add this line to the bottom:

    $config['enableListeners'] = false;

    Then try and upgrade again.
  3. Mike

    Mike XenForo Developer Staff Member

    That really just looks like an upload issue. I'd recommend reuploading everything.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Try a different FTP program.
  5. Chris D

    Chris D XenForo Developer Staff Member

    Keep a very close eye on your FTP console. It should pretty much list the transfer status of all files. See if you can tell which file it is failing on. It might be a permissions thing that's blocking the file from being uploaded.
  6. Tobseb

    Tobseb Member

    Nope, I am not able to get into the ACP.

    Already tried to reupload it a few times.

    Just tried it with the "$config['enableListeners'] = false;" ... Still the same Error. "$config['debug'] = true;" also does not improve anything.

    I will try a different FTP program now ( used FileZilla so far ).
  7. Brogan

    Brogan XenForo Moderator Staff Member

    For future reference, this is a bad idea.

    The error messages are there for a reason.
    LPH likes this.
  8. Tobseb

    Tobseb Member

    There is one Error. "/library/Zend/Feed/Pubsubhubbub/Http" -> "Create Folder" . Idk why that one fails, but in the folder there is not even anything in it... ?
  9. Brogan

    Brogan XenForo Moderator Staff Member

    All the indications point to a corrupt/incomplete .zip or an FTP issue.

    Download the .zip again, use a program other than Filezilla.
  10. CyberAP

    CyberAP Well-Known Member

    That happens with my installation every time but upgrades were OK.
  11. Tobseb

    Tobseb Member

    Currently uploading everything using WinSCP. Hopefully that will work.
  12. Tobseb

    Tobseb Member

    Same thing ... Now there are 2 file(s) invalid ... >.<

    I will try it again now with filezilla and the upgrade package.
  13. Brogan

    Brogan XenForo Moderator Staff Member

    Are you actually using the full .zip to do an upgrade?

    You do realise the implications of that?
  14. Rob

    Rob Well-Known Member

    Can u explain Brogan?

    Incidentally... I downloaded rc2 just earlier and am half way through CLI upgrade using the full zip. Its just a test upgrade.
  15. Tobseb

    Tobseb Member

    Yep, I latest used the full package...
  16. Brogan

    Brogan XenForo Moderator Staff Member

    What is the difference between the upgrade and full packages?
    The upgrade package does not include the following files and directories:

    You stand the risk of overwriting content and potentially losing avatars and attachments, depending on how the FTP program is configured.
  17. Tobseb

    Tobseb Member

    .htaccess and config.php was not overwritten for me. Avatars are still existing so far. That would be OK for me. The installation is pretty new. But I still do not know, how to get through the upgrade now. Same thing as before. :|
  18. Brogan

    Brogan XenForo Moderator Staff Member

    My mistake on config.php, it's not included.
  19. Rob

    Rob Well-Known Member

    Thanks for the clarity :)
  20. Tobseb

    Tobseb Member

    And what should I do now? ...

Share This Page