1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TPU: Add Signature Pictures 1.0.0

Lets users upload images to use in their signature, like on vBulletin.

  1. W1zzard

    W1zzard Well-Known Member

    W1zzard submitted a new resource:

    TPU: Add Signature Pictures (BETA) - Lets users upload images to use in their signature, like on vBulletin.

    Read more about this resource...
     
    z3r010 likes this.
  2. W1zzard

    W1zzard Well-Known Member

    Does anyone know how to get the posting user's data when rendering a signature below a post? (not XenForo_Visitor). Right now I'm putting the user's Id between sigpic tags, but ideally this addon should work without.
     
  3. W1zzard

    W1zzard Well-Known Member

  4. RoldanLT

    RoldanLT Well-Known Member

    This feature should be core.
     
    z3r010 likes this.
  5. Echelon

    Echelon Active Member

    Is it possible to give permissions? I mean.....I just want a real close [group] of people give rights to upload a visual + link in their signature.

    Thanks
     
  6. W1zzard

    W1zzard Well-Known Member

    There are no additional permissions created by this mod at this time
     
  7. RoldanLT

    RoldanLT Well-Known Member

    Can you please add:
    • Minimum post count
    • Minimum registered days
    • Minimum Like Count (maybe) :)
    settings/option to set?
     
  8. W1zzard

    W1zzard Well-Known Member

    Seems there is very little interest for this addon, so not very motivated to invest time for user requests.
    If I make any changes to the plugin on my own forum, I'll update the release here of course.
    Also I'll happily accept code submissions from users to update the plugin.
     
    RoldanLT likes this.
  9. Ken Retroids

    Ken Retroids Member

    I'm surprised there aren't more interested in this! Looks great so far!
     
  10. RoldanLT

    RoldanLT Well-Known Member

    Because of the BETA title :D
     
  11. Ken Retroids

    Ken Retroids Member

    The only real major improvement I can think of would be usergroup permissions, so I can reward those who donate to our site with larger image sigs, etc. Maybe the ability to limit the image type (gif, jpg png). Great work so far!
     
    RoldanLT likes this.
  12. RoldanLT

    RoldanLT Well-Known Member

    I got this:
    Server Error
    Mysqli statement execute error : Duplicate column name 'sigpic_date'

    1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    3. Zend_Db_Adapter_Abstract->query() in TPUSigPic/Listener.php at line 8
    4. TPUSigPic_Listener::install()
    5. call_user_func() in XenForo/Model/AddOn.php at line 215
    6. XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
    7. XenForo_Model_AddOn->installAddOnXmlFromFile() in AddOnInstaller/ControllerAdmin/AddOn.php at line 36
    8. AddOnInstaller_ControllerAdmin_AddOn->actionInstallUpgrade() in XenForo/FrontController.php at line 347
    9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    10. XenForo_FrontController->run() in /admin.php at line 13
     
  13. RoldanLT

    RoldanLT Well-Known Member

    I think, I already installed this before, then removed.
    Now when trying to install again, receive that error.
     
  14. W1zzard

    W1zzard Well-Known Member

    Hmm... this error means that the column the addon puts in the database wasn't removed properly when you uninstalled. normally the addon should remove its column automatically on uninstall.

    You can manually remove the column sigpic_date from the table xf_user (ALTER TABLE xf_user DROP sigpic_date) or edit listener.php in the addon, remove the query statement from the install function in that file.

    I'll try to reproduce and release a fixed version (not very soon, a bit busy atm)
     
    RoldanLT likes this.
  15. RoldanLT

    RoldanLT Well-Known Member

    I un-install it then install, fixed.
     
  16. RoldanLT

    RoldanLT Well-Known Member

    Should I enable Image on Usergroup permission for this to work?
    Here's my current settings.
    upload_2014-1-10_23-18-21.png
    After putting [sigpic][/sigpic] on the signature editor, then saved doesn't work.
    I try to reload the page, and the bb code inserted is gone, so maybe is filtered?
     
  17. RoldanLT

    RoldanLT Well-Known Member

    I'm using memcache, ngx_pagespeed, apc on my Forum.
    Maybe my first 5 attempt on saving the Signature Editor didn't work.
    [sigpic][/sigpic] disappear when I reload the page.

    I tried as many times, then it saves now.
    Work as expected.

    I'm curious as to what is the reason it didn't save on my first few attempt?
    Maybe caching cause it?
     
  18. RoldanLT

    RoldanLT Well-Known Member

    Please add a new feature similar to avatar, that admin can delete/replace on admin page. :)
     
  19. RoldanLT

    RoldanLT Well-Known Member

    Last edited: Jan 12, 2014
  20. W1zzard

    W1zzard Well-Known Member

    Great feedback. Thanks!

    Can you check if disabling apc/memcache/parse cache helps?

    I'm using memcached myself and haven't been seeing that issue.
     

Share This Page