TinyMCE Fix (NO MORE SUPPORTED)

TinyMCE Fix (NO MORE SUPPORTED) 0.7.1

No permission to download

ashkir

Active member
Code:
XenForo editor ctrl_message, [
<textarea name=​"message_html" id=​"ctrl_message_html" class=​"textCtrl MessageEditor" style=​"height:​ 260px;​ display:​ none;​ " aria-hidden=​"true">​</textarea>​
] add-reply:407
XenForo.activate(
HTMLDocument
) xenforo.js:191
flash url: http://rpg-directory.com/js/swfupload/Flash/swfupload.swf attachment_editor.js:6
Attachments changed, total files: 0, images: 0 attachment_editor.js:13
XenForo.init() 66ms. jQuery 1.5.2/1.2.6-dev xenforo.js:188
2PPB_Graphics2D.PaintImageData: Rectangle is outside bounds.
SWFUpload successfully initialized (SWFUpload_0) attachment_editor.js:7
2PPB_Graphics2D.PaintImageData: Rectangle is outside bounds.
Abort pending field validation... xenforo.js:291
POST http://rpg-directory.com/threads/advertising-rules-say-what.46437/add-reply
 

cclaerhout

Well-known member
I've just noticed that my minify version of TinyMCE doesn't load on Opera. It seems the Microsoft JavaScript Compressor has some problem with it.

I will upload a new archive today.


Edit: TinyMCE really needs to be compressed with the YUI compressor.
Here is an online version
 

cclaerhout

Well-known member

Adam Howard

Well-known member
I wonder how hard it would be to impute the full TinyMCE editor into XenForo

By full I mean all the bells and toys that normal TinyMCE has.
 

cclaerhout

Well-known member
I wonder how hard it would be to impute the full TinyMCE editor into XenForo

By full I mean all the bells and toys that normal TinyMCE has.

XenForo is already using the full TinyMCE. I mean it doesn't use the Bb Code TinyMCE plugin. Developers have created a full parser to convert some html code to Bb Codes (and the same function to convert them back to html).

So if you want to use a TinyMCE plugin which is not inserting a new html code, it won't be a problem. For example, I'm waiting the release of the next version of the Bb Codes Manager to release the official autosave tinymce plugin. I would just need to update a little its Javascript code to make it work with XenForo.
 

Adam Howard

Well-known member
XenForo is already using the full TinyMCE. I mean it doesn't use the Bb Code TinyMCE plugin. Developers have created a full parser to convert some html code to Bb Codes (and the same function to convert them back to html).

So if you want to use a TinyMCE plugin which is not inserting a new html code, it won't be a problem. For example, I'm waiting the release of the next version of the Bb Codes Manager to release the official autosave tinymce plugin. I would just need to update a little its Javascript code to make it work with XenForo.
:notworthy:

Ideally, I'd like to be able to just download TinyMCE and upload it to XenForo. I'm sure there is away to do it without having to edit TinyMCE each time for it to work with XenForo
 

cclaerhout

Well-known member
I didn't know what to do with the attached patch, so I put it here instead of creating a new resource that might be confusing.
This patch is the Xenforo original TinyMCE files (version 3.4.2) which have been modified to fix a problem of insertion with Opera (the last version of TinyMCE doesnt have this problem). See the problem here. See the patch here made by a user. This problem was discovered on XenForo by vkams (see here) when he was using the QuoteME addon.

If you don't want to install the TinyMCE fix, you can still download the attached patch and keep your XenForo original TinyMCE.
 

Attachments

  • TinyMCE XenForo Original Fix.zip
    161.3 KB · Views: 11

lasertits

Active member
Very glad to see someone giving TinyMCE for XF some much needed TLC. It seems to work great thus far, and I'm not sure if this is just me with this issue (I'm presuming it is but figured I'd post this up before digging too deep), but I can't get code to insert into the editor. Neither General, PHP, or HTML work.

Made a quick screencast demonstrating the issue, you can watch these in full screen to see it in detail if need be:
-snip-

Chrome Console Screencast:
-snip- (some errors/alerts appear when the code overlay opens, and more when attempting to insert)

Chrome Console Screenshot (screencast doesn't have everything): -snip- - for comparison, here's chromes console after inserting code using the old TinyMCE without the addon: -snip-

Any ideas? I hope I'm not posting this prematurely, though it's quite possible as I am sleep deprived and have been working on site related junk for the past 16 hours.

The 404 in chrome's console is XF looking for a now non-existent JS file apparently (/js/tinymce/themes/xenforo/js/code.js - I only have editor_template.js & editor_template.sedo.src.js in that directory), not sure why that's happening. Been messing with the addon for the past hour or so and this is the only issue I've come across thus far, rest appears to work great. If this is an isolated issue, any insight on how I might go about fixing it would be very appreciated.

Addon version 0.3, Chrome 22.0.1229.94 m

Thanks.
 

cclaerhout

Well-known member
How did you install this addon? You musn't delete your TinyMCE directory (I didn't put inside the archive all XenForo TinyMCE private files ; I just put one because I had to), you have to copy above the existing files.
 

lasertits

Active member
How did you install this addon? You musn't delete your TinyMCE directory (I didn't put inside the archive all XenForo TinyMCE private files ; I just put one because I had to), you have to copy above the existing files.
Doh... that was definitely the issue. I didn't combine them (renamed tinymce to tinymce_old for easy restore, was my thinking), just blindly presumed the included files was everything I needed. Not sure why it didn't register to me when I saw that 404 missing the code.js...

Now that that's all working fine, time to get some much needed sleep to avoid simple mistakes like this. :oops:

Thanks!
 

vkams

Active member
This patch is the Xenforo original TinyMCE files (version 3.4.2) which have been modified to fix a problem of insertion with Opera (the last version of TinyMCE doesnt have this problem). See the problem here. See the patch here made by a user. This problem was discovered on XenForo by vkams (see here) when he was using the QuoteME addon.
Thank you, Cédric, from me and my forum' users, now I can enjoy improved version of QuoteME!
 

cclaerhout

Well-known member
The same problem I had in post#52 I am having with adding images.
The developer of TinyMCE didn't find anything (see here)
I asked you if you had any error message inside the console (see here)
On Windows there is no problem, I'll put a screenshot later (I had to install a previous version).

Now just to check, when you say you're using a Mac, is it a phone or a tablet? If yes, the problem has already been sent here.

Edit:
chrome-windows.png

May be the problems comes from all Mac version. I just need you confirm this information and you look inside your Javascript console to catch the error message.
 
Top