XF 2.2 Time Stamp Is Off By 4 Hours

Serpius

Active member
Disregard the wording of the error line... I am focusing on the time stamp of this log.

The log was stamped at 4:54 am, but my current time (at the time of the log creation) was 12:54 am.

My time zone is the US Eastern time zone, which currently is a 4-hour difference from the UTC Time zone.
My time zone of US Eastern is already done in the AdminCP settings.

Is there any way that I can have the logs time-stamped to my local time zone?

4202D1D6-FBCB-4C02-AA85-9C50574397D0_4_5005_c.jpeg
 

bzcomputers

Well-known member
Are far as I know all things like logging, cron jobs, scheduled posts, etc. all are currently hard coded to GMT/UTC.

There is a already a suggestion for adding the ability for admins to set the local timezone here:

Someone may have an idea of a work around for you, but I believe adding the ability for the admin to set the local timezone (as in the suggestion above) is probably what you want also.
 

Serpius

Active member
Just setup your timezone in user details? I don’t have problem like this, I see all log entries in my local time (GMT+4).

No, that doesn't work. That's only for users to adjust their accounts to their own timezone.

This has to do with the AdminCP logs that Admins review. It's a different situation.
 

Kruzya

Well-known member
What’s wrong here with timestamps? I don’t see any issues. All time is correct.
Noted error logs displays correctly too.
 

Attachments

  • E33B9A70-C186-4A1D-8691-E0FF426E992E.png
    E33B9A70-C186-4A1D-8691-E0FF426E992E.png
    255.6 KB · Views: 7

Kruzya

Well-known member
I re-read and i don't understand your problem.

XF uses GMT/UTC as primary format for storing all datetimes. This can be checked with simple changing timezone.
This screenshot i created with GMT+4:
1631386147690.png

Then i changed in preferences timezone to GMT+3:
1631386250465.png

On screenshot you can see another issue with displaying datetime, i already reported them, but it looks like another issue related with same problem.
 
Top