1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Thumbnail and full image buttons missing

Discussion in 'Installation, Upgrade, and Import Support' started by Deputy Dog, Feb 28, 2012.

  1. Deputy Dog

    Deputy Dog Member

    Hi folks,

    Hope you will all forgive my newbie questions as I'm sure I will be posting quite a few of them until I get up to speed with xenForo.

    Here's my issue. I just migrated a recently purchased website from one server to another. Apparently one or two fairly minor items broke in the transition. Here is a screen shot of "Upload Attached Files" dialog box on my old server:


    and here is how the same page looks on my new server after the migration:

    As you can see, the "Thumbnail & Full Image buttons and the small preview of the file are missing in action . Any help or instruction to resolve this issue is greatly appreciated. Remember, xenForo is new to me so please explain any suggestions in layman's terms!

  2. Brogan

    Brogan XenForo Moderator Staff Member

    The thumbnail and full image buttons are not available as the attachment is not being recognised as an image file.

    Something appears to have been changed during the import from one server to another and the file is not being accepted as a valid JPG.

    Typically this is when the file extension is incorrect, e.g JPG when it should be PNG.

    Download the file and see if you can open it in a normal image program to confirm the extension.
  3. Deputy Dog

    Deputy Dog Member


    I can download the file and then open it without issue using any image program. I used Picasa and ACDSee to confirm.

    I have noticed these statements in my ACP server error logs that may be related to this issue as it tends to appear at the same time that an image is uploaded:

    Mysqli statement execute error: Column 'album_id' cannot be null
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. Deputy Dog

    Deputy Dog Member

    350 X 539 Pixels or 185 KB (small picture of a dog) I know that in the past, the program will return a 'file too big' message when members try to upload huge pictures
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Then my first comment still stands.
    The system doesn't recognise it as a valid image file for some reason.
  7. Deputy Dog

    Deputy Dog Member

    Any ideas on a fix? Maybe a copy and paste the file responsible from the old server? What module is responsible for this action?
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Are all of the imported attached files showing like that?
    I had the same problem with some (not all) images when I imported from phpBB.

    The solution was to download the attachments, re-save them and then upload again.

    A tedious process but it was the only way of resolving it without identifying and fixing the underlying issue and redoing the import.
  9. Deputy Dog

    Deputy Dog Member


    No, all of the previously uploaded pictures (JPEG, PNG, etc.) that are part of the before the migration database display normally. All member photo albums likewise look fine. The problem seems to be with the uploader (flash?) module / function now after the migration. Sorry, I'm not really fluid yet with the hiearchy of the xenForo platform.
  10. Brogan

    Brogan XenForo Moderator Staff Member

    Doing an import shouldn't affect the functionality as the server files aren't affected.

    Can you link me to your site and provide a test account so I can do some tests?
  11. Deputy Dog

    Deputy Dog Member

    Yes, I will PM you the information as soon as I have it done. :)
  12. Brogan

    Brogan XenForo Moderator Staff Member

    OK I've confirmed the problem.

    You do though have a lot of add-ons installed and almost 3,000 entries in the error log, including some from today.

    I ran the file health check and the only one which failed is: library/Merc/DonationProcessor/PayPal.php

    I also tried disabling the flash uploader but the result was the same.

    All I can suggest is you disable all add-ons and try using a default, unedited style.
    It's possible that one or more of the installed add-ons are the cause of the problem but until we get back to a working baseline, we won't be able to determine which one(s).
  13. Mike

    Mike XenForo Developer Staff Member

    Make sure you're set to GD if you're not already.

    If you are, then GD is compiled without the necessary file type support options. Depending how PHP has been setup, you may need to recompile it. (Or talk to your host.)
  14. Deputy Dog

    Deputy Dog Member

    (Sigh...) I was hoping for a magic fix! Thanks for looking around Brogan, I do appreciate it.
  15. Brogan

    Brogan XenForo Moderator Staff Member

    I should have mentioned that it was already set to GD; Imagick isn't installed so isn't an option.
  16. Brogan

    Brogan XenForo Moderator Staff Member

    Ah, I've just noticed this <facepalm>
    For some reason I read that as being an import, not a server move.

    In which case Mike is more than likely on the right track.
  17. Deputy Dog

    Deputy Dog Member

    A little more info.

    This xF ACP error appears to be related to issue. Does it offer any clues?

    Server Error Log

    Error Info
    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Column 'album_id' cannot be null - library/Zend/Db/Statement/Mysqli.php:214
    Generated By: Unknown Account, Yesterday at 1:35 PM
    Stack Trace
    #0 /home/caninech/public_html/community/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
    #1 /home/caninech/public_html/community/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
    #2 /home/caninech/public_html/community/library/XfRu/UserAlbums/Model/Albums.php(218): Zend_Db_Adapter_Abstract->query('????INSERT DELA...', NULL)
    #3 /home/caninech/public_html/community/library/XfRu/UserAlbums/ControllerPublic/Albums.php(285): XfRu_UserAlbums_Model_Albums->logAlbumView(NULL)
    #4 /home/caninech/public_html/community/library/XenForo/FrontController.php(310): XfRu_UserAlbums_ControllerPublic_Albums->actionView()
    #5 /home/caninech/public_html/community/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #6 /home/caninech/public_html/community/index.php(13): XenForo_FrontController->run()
    #7 {main}
    Request State
    array(3) {
    ["url"] => string(64) "http://canine-chat.com/community/index.php?useralbums/kay.8/view"
    ["_GET"] => array(1) {
    ["useralbums/kay_8/view"] => string(0) ""
    ["_POST"] => array(0) {
  18. Brogan

    Brogan XenForo Moderator Staff Member

    That's not connected, although it does indicate a problem with the album add-on.
    Deputy Dog likes this.
  19. Deputy Dog

    Deputy Dog Member

    I fixed it Brogan! Thanks for the help!
  20. Gabriel Pinho

    Gabriel Pinho Member

    I got the same error after a server migration....

    Small Images of Attached Images show as a error:


    As the XenPorta uses this miniature images:


    Image in normal sizes isnt have a problem to be show.

    All kind of files, all kind of extension i take this error. Before the migration was normal. I changed the permission's path to 777, nut the error still there.

    Any idea to solve it?

Share This Page