1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Thread reply email issue

Discussion in 'Troubleshooting and Problems' started by Stemmy, Oct 6, 2014.

  1. Stemmy

    Stemmy Active Member

    I've had a couple of members asking a question.

    When they get the email to say that somebody has replied to their thread the link in the email does not work correctly.

    After looking I noticed that the link does not start www.

    When I click the link it works fine but they have said when they click it it goes to a generic welcome page with an error and asks them to login. Even though they are logged in at the time ??

    So the link works for me and others but doesn't work for some. i assume its a local setting for them. If they add the www. then the link works fine.

    Is there a way I can get it to add the www. because I would assume that would sort the problem for everybody.
  2. Chris D

    Chris D XenForo Developer Staff Member

    Check the value you have set in Admin CP > Options > Basic Board Information > Board URL
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Ensure your site isn't available via www and without www.
    If it is, force it to one or the other using .htaccess.

    Update the Board URL in the ACP to match.
    Chris D likes this.
  4. Stemmy

    Stemmy Active Member

    done thanks guys.
  5. Chris D

    Chris D XenForo Developer Staff Member

    Did you follow @Brogan's advice about redirecting from the non www URL to www?

    That's definitely great advice.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Chris D likes this.
  7. Stemmy

    Stemmy Active Member

    I had the wrong url in the admin. So changed that.

    What do I need to add to the htacess to force it to one of the urls

    Thanks in advance guys. The support here is second to none.
  8. Brogan

    Brogan XenForo Moderator Staff Member

  9. Stemmy

    Stemmy Active Member

    Thanks Brogan

    I read through the thread and added the modified code to my htaccess file - nothing seems to have changed .

    The code I added was

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^www.photography-forum.org$ [NC]
    RewriteRule ^(.*)$ https://www.photography-forum.org/$1 [R=301,L,QSA]
    # If you are having problems with the rewrite rules, remove the "#" from the
    # line that begins "RewriteBase" below. You will also have to change the path
    # of the rewrite to reflect the path to your XenForo installation.
    RewriteBase /

    # This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]


    Does that sound right ? My forum is on a https
  10. Brogan

    Brogan XenForo Moderator Staff Member

    You may need to try some variations, all servers are different.

    This was the only thing which worked for me:
    RewriteCond %{HTTP_HOST} www.cliptheapex.com$
    RewriteRule ^(.*)$ http://cliptheapex.com/$1 [R=301,L]
    Also, make sure you are editing the .htaccess file and not the htaccess.txt file.
  11. Stemmy

    Stemmy Active Member

    I have tried every variation on that thread and still cant get it to redirect.
  12. Stemmy

    Stemmy Active Member

    Ahh yes !!!!! - good thinking :) view hidden files :)
  13. Chris D

    Chris D XenForo Developer Staff Member

    Is it an Apache server or nginx?
  14. Stemmy

    Stemmy Active Member

    I have found the correct file now and the code is - It looks a bit different as my site is https - Not sure what to replace


    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    RewriteEngine On
    RewriteRule ^showthread\.php/([0-9]+)-[^/]+$ /index.php?threads/$1/ [R=301,L]

    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default

    <IfModule mod_rewrite.c>
    RewriteEngine On
  15. Stemmy

    Stemmy Active Member

    not sure - you might know better than me - Im with Nimbus ??
  16. Stemmy

    Stemmy Active Member

    I gave up in the end - i tried everything apart from my last resort :)

    My ace up my sleeve :)

    Slavic helped migrate my forum so I sent him a message, 30 seconds later and it was done. The guy is a genius :)
    Slavik likes this.

Share This Page