1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 This attachment cannot be shown at this time. Please try back later.

Discussion in 'Troubleshooting and Problems' started by Nudaii, Mar 29, 2013.

  1. Nudaii

    Nudaii Well-Known Member

    I recently moved from one host to another, and now whenever i click any attachments from before the move i get this message

    This attachment cannot be shown at this time. Please try back later.

    however any new attachments works, and the files are physically still in the data/internal_data folders

    any ideas?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Is it a caching issue?

    What is the URL of previously uploaded attachments when you try to load them?

    Or it could be due to file server permissions.
    Nudaii and Chris D like this.
  3. Chris D

    Chris D XenForo Developer Staff Member

    I guess just make sure the old files themselves are actually readable by the web server. It has been known for file permissions to change during the copy phase and although the parent folder might be the same, somehow those files are set to be unreadable for some reason.

    EDIT: [​IMG]
  4. Nudaii

    Nudaii Well-Known Member

  5. Brogan

    Brogan XenForo Moderator Staff Member

    You can navigate directly to the full sized attachment in your browser?
  6. Nudaii

    Nudaii Well-Known Member

    no it gives the error mentioned in first post.

    all very confusing
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Can you post the URL of one publicly accessible attachment - i.e. one that isn't restricted for guests?
    Nudaii likes this.
  8. Nudaii

    Nudaii Well-Known Member

  9. sonnb

    sonnb Well-Known Member

    This message would be shown if attachment is unreadable (removed or no permission).
  10. Brogan

    Brogan XenForo Moderator Staff Member

    That attachment is not accessible to guests.
    Nudaii likes this.
  11. Nudaii

    Nudaii Well-Known Member

    sorry about that. try now:)
  12. Brogan

    Brogan XenForo Moderator Staff Member

    According to Firebug, it's a 404.

    Have you confirmed the attachment is actually in the directory?
    You can check using WinSCP or similar.
    Nudaii likes this.
  13. Nudaii

    Nudaii Well-Known Member

    do you mean in /internal_data/attachments/0?
  14. Brogan

    Brogan XenForo Moderator Staff Member

    Yes, and data/ for the thumbnail.
    Nudaii likes this.
  15. Nudaii

    Nudaii Well-Known Member

    well so it was, seems filezilla failed all the .data transfers

    Did it via ssh and it worked this time

  16. CaptainMorgan

    CaptainMorgan Active Member

    Seems I'm having a similar issue, same error message.

    I've confirmed the attachments do exist in /data, yet I would not know how to do so in /internal_data/attachments - how can I read the .data files?

    Anyways, I also gave the entire root directory and forward to these attachments www-data rights, and even set the attachments themselves to 755.

    Any ideas? I believe this is also related to user avatars... as an admin, only mine is visible, yet it appears that no one else's avatar is set. I logged in as a test user, changed my avatar and it stuck. But when I went back to admin, that avatar for the test user was not set, which I find very weird...

    Using 1.3.1. thanks
  17. CaptainMorgan

    CaptainMorgan Active Member

  18. Mike

    Mike XenForo Developer Staff Member

    You just need to check that an internal_data/ record exists at the correct place. The data is just what's uploaded -- you can rename the extension. This error generally indicates that the file doesn't exist or can't be read.

    What changed from when it worked to when it didn't? Figuring that out and either undoing it or figuring out the significance is the key to this.

Share This Page