• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

As designed There's a lot of space between some custom thread fields and their values

Affected version
2

Mike

XenForo developer
Staff member
#2

Steve F

Well-known member
#3
On my iPhone I’m seeing this:
IMG_0116.PNG

With more fields I think it could look confusing as there really isn’t any styling to indicate the “2” belongs to the label above it.

Edit: iPhone 7 Plus iOS 11 (beta 3)
 

Mike

XenForo developer
Staff member
#4
There is (or there will be) additional spacing between fields when they flip to the vertical display that should make it clearer. Our forms (and form row styled elements) have flipped to a vertical arrangement since older versions of XF1 and I don't think there's been an issue with that.
 

RobinHood

Well-known member
#5
It's not really, though clearly it looks it with a particularly small title. The spacing is identical to the fields here: https://xenforo.com/community/resources/sandbox-paypal.5132/ It's also the same here: https://xenforo.com/community/members/martok.46288/#about

As such, this is really going to be as designed. The only real alternative would be to not try to align them, though with multiple fields that's likely to look terrible.
Ah, I see, perhaps it could do with the grey line break between the custom field and the text part of the post? As per the resource page.
It would help give a little differentiation between the two parts of the post.

Screenshot 2017-08-12 18.04.44.png
 

Digital Doctor

Well-known member
#6
The only real alternative would be to not try to align them, though with multiple fields that's likely to look terrible.
Actually this looks like a bug to me as a user.
1502560495640.png

would not aligning things that only have 1 custom field solve this issue ?

Xenforo 1 used this alignment method on the dual login/sign up

1502560691318.png

Is it going to be a common use of custom thread fields to have just one per thread ?