1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 There was a problem uploading your file. Error

Discussion in 'Troubleshooting and Problems' started by RoldanLT, Jan 10, 2014.

  1. RoldanLT

    RoldanLT Well-Known Member

    My Maximum Attachment File Size (KB) = 2048

    When I use Flash Uploader, I got this error:
    upload_2014-1-10_19-16-29.png

    When I disable the Flash Uploader, I got this:
    upload_2014-1-10_19-18-11.png


    I read a lot of similar threads here, but didn't help.
    I'm on Nginx server, without GUI Control panel (Centmin Mod)

    Anybody already experience this kind of error?
     
  2. RoldanLT

    RoldanLT Well-Known Member

    Adding this to my config.php
    ini_set('post_max_size', '32M');
    ini_set('upload_max_filesize', '32M');

    Didn't fix it.
     
  3. RoldanLT

    RoldanLT Well-Known Member

    My Phpinfo:
    max_execution_time = 60
    memory_limit = 128M
    post_max_size = 15M
    upload_max_filesize = 15M
     
  4. RoldanLT

    RoldanLT Well-Known Member

    Mysql Settings:
    max_allowed_packet = 32M


    And the error display just after you hot the button upload/open.
    No uploading progress is shown.

    But I can upload images below 1mb.
     
  5. RoldanLT

    RoldanLT Well-Known Member

    And I'm using ImageMagick PECL Extension as Default Image Processor.
    Even if using GD, same error.
     
  6. Mike

    Mike XenForo Developer Staff Member

    It's certainly possible that the web server is effectively blocking the request. You can see some discussion here about increasing the max body size in Nginx: https://rtcamp.com/tutorials/php/increase-file-upload-size-limit/

    If that doesn't help, please try disabling JS entirely in your browser and see what happens when you try to upload a file (this will prevent any errors from being hidden).
     
    RoldanLT likes this.
  7. RoldanLT

    RoldanLT Well-Known Member

    Fixed now :D
    Didn't realize it was the issue :)
    Thanks !
     
  8. RobParker

    RobParker Well-Known Member

    What was the solution?
     
  9. RoldanLT

    RoldanLT Well-Known Member

    client_max_body_size :)
     
  10. RobParker

    RobParker Well-Known Member

    Our host set that to 10MB and now I can upload fine on our live site but on our test site it's still giving that error.

    As our test site was just a copy of our live site on the same server I can't think of any reason why they'd differ?

    Any ideas?
     

Share This Page