1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"The server did not respond in time. " editing template

Discussion in 'Troubleshooting and Problems' started by jgas, Mar 7, 2012.

  1. jgas

    jgas Active Member

    since my upgrade to xenforo 1.1.2 ( I was on 1.1.0 until yesterday), when I try to save some templates (not all), the page keeps on loading for a minute or more, and in the end I get this error:

    The following error occurred:
    The server did not respond in time. Please try again.

    But then, when I reload the edit template page, I see that all my modifications were saved.

    Why ?
    I tried it with "minify css" and "Fetch public templates as files" On or Off, adding or removing the xcache configuration to the config.php , but I still get the same problem.

    EDIT: data and internal_data directories are writeble.

    What can I do?
  2. bambua

    bambua Well-Known Member

    I know this is going to sound strange but have you tried a different browser/clearing the cache on your browser. I had this happen to me at one point.
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    This can sometimes happen if you have a lot of styles installed. You should remove any excess styles that you don't need or aren't using.
    jgas likes this.
  4. Mutt

    Mutt Well-Known Member

    i sometimes get it & only have the 1 style installed. not sure why
  5. vij

    vij Active Member

    I get the same error "The server did not respond in time. Please try again. - "while editing and saving posts but then things do get done - but why the error?. Also when the post is saved there should be a clear indication that says things are processing so that users stop clicking repeatedly.
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That can be the result of a failed or slow SMTP connection (when sending notification emails on reply). A failed SMTP connection will normally show in the log:

    Admin CP -> Tools -> Server Error Log

    If the log contains mail errors then you need to check your SMTP info:

    Admin CP -> Home -> Options -> Email Options
  7. vij

    vij Active Member

    No errors in Server Error Log
    btw, I just changed the timeout thingy in xenforo.js from 30 to 50secs. Hope it will help.

    Also something else. Sometimes it takes around 3 seconds for the message to be posted (especially if the message is edited and saved) - users tend to click it a few times thinking nothing is happening as there is not too obvious an indication that something is happening in the background.
  8. CyclingTribe

    CyclingTribe Well-Known Member

    Do you have any caching installed/configured on your server?
  9. vij

    vij Active Member

    I am a noob when it comes to all this. Wouldnt that be by default - if not, How do I do it? I am on shared hosting(highest plan though) currently with cpanel access.
  10. CyclingTribe

    CyclingTribe Well-Known Member

    If you're on shared hosting, just ask your host if they have any caching on the server, such as APC, memcached, eAccelerator, etc. - I would imagine they would have, but it's worth asking, just to check. (y)

    If they do have caching on the server you should be able to adjust your XF config file to take advantage of it.

Share This Page