1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The File Too large for the server

Discussion in 'Troubleshooting and Problems' started by faeronsayn, Oct 19, 2012.

  1. faeronsayn

    faeronsayn Well-Known Member

    The following error occurred

    The uploaded file is too large for the server to process.


    I've randomly just started getting this error when uploading basically any file, even images that are 50kb in size. I turned out debug mode but the error stays the same without giving much more information. I've re-checked my php.ini file and made sure all of the memory_size and max_file_upload were more than their default values. I also restarted apache to make sure those values were applied.

    Could it have something to do where the files are actually being stored in? I have two HD on my server and my website and all it's file is on another HD while my database is on the SSD. However, I don't think that should really matter.
  2. Digital Doctor

    Digital Doctor Well-Known Member

    Other Xenforo users have had this.
    This same error has occurred on all forum software packages.

    Did anyone else's solutions help ?

    Are you running a VPS ?
  3. faeronsayn

    faeronsayn Well-Known Member

    Yea this is on a VPS.
  4. EQnoble

    EQnoble Well-Known Member

    In your php.ini have you tried to increase the execution time allowed
  5. faeronsayn

    faeronsayn Well-Known Member

    this "max_execution_time = 60" ?

    I've changed it to 60 from 30.
  6. EQnoble

    EQnoble Well-Known Member

    could you pm me your full php.ini config and just scrub out any sensitive information....it may help me help you.
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That particular error probably means you hit a server limit. Here are some server settings that may be limiting:



    Or more generally, that error means the temp file from the upload doesn't exist. So it's a server something or other. Could also be a lack of write permissions in /tmp, though I would expect a permission error if that were the case.
  8. faeronsayn

    faeronsayn Well-Known Member

    It was the tmp directory which seemed to have been filled. Deleting some content in it basically solved the problem.
    Digital Doctor and Jake Bunce like this.

Share This Page