1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue Text input error - iOS 8.2

Discussion in 'Resolved Bug Reports' started by Curt Lewis, Mar 31, 2015.

  1. Curt Lewis

    Curt Lewis New Member

    Go to any screen where you would input text - create a thread, reply, conversation, etc.

    Tap the microphone and speak the text.
    Click done when you've finished speaking.


    All the text that was translated disappears.

    Expected Result:
    the text that was on screen remains on screen for you to edit or add to.

    Occurs on two forums that I've tried:


    iPhone 6
    iOS 8.2
  2. Curt Lewis

    Curt Lewis New Member

    Also occurs here in this thread.
  3. Chris D

    Chris D XenForo Developer Staff Member

    I am currently running iOS 8.3 beta and it is working as I would expect it to.

    The above sentence was dictated in Chrome and it seems to work fine.

    I am now performing the test in Safari. It also seems to be working okay.

    We may have to wait this one out a bit. If anyone else with iOS can give it a try and report back your results and iOS version that would be useful.
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    It's working for me on 8.1.
  5. AndyB

    AndyB Well-Known Member

    Worked fine for me on iOS 8.1 using my iPad. I then upgraded to iOS 8.2 and it fails as Curt describes. As soon as I hit the Done button on the iPad to finish the dictation, the text which was dictated is erased as if I hot the back arrow to the point where it started the dictation.
  6. Chris D

    Chris D XenForo Developer Staff Member

    I can test this with iOS 8.2 on my wife's iPad and iPhone so will let you know but at the moment I believe this to be an iOS bug which is fixed in iOS 8.3.
  7. Chris D

    Chris D XenForo Developer Staff Member

    I have now confirmed the issue only exists in iOS 8.2, seemingly fixed in iOS 8.3, only affects Safari and most importantly problematic with any html element that accepts text input. I have tested it in a textarea outside of XF and the problem persists. Hence Browser Issue / Not a Bug.
  8. Chris D

    Chris D XenForo Developer Staff Member

    I can confirm this works fine now that iOS 8.3 has been officially released.
    AndyB likes this.

Share This Page