1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

System Requirments & safe_mode

Discussion in 'XenForo Pre-Sales Questions' started by mdj101, Jan 10, 2015.

  1. mdj101

    mdj101 New Member

    Hi All,

    I've run the xenForo pre installation system requirements script and it reports

    1. PHP must not be running in safe_mode. Please ask your host to disable the PHP safe_mode setting.
    I've turned this off on the server, but the script is still reporting the same?

    From phpinfo

    safe_mode Off Off
  2. Fred.

    Fred. Well-Known Member

    Did you restart your httpd after you made the change?
  3. mdj101

    mdj101 New Member

    I didn't need too as it was showing on the phpinfo.php as off, but I've restarted the server and I'm still getting the same message.

    safe_mode is off but the script is telling me it's not.

    I'm ready to buy the software but I'm not going to waste my money If it won't work.
  4. batpool52!

    batpool52! Well-Known Member

    Have you checked your htaccess file?
  5. mdj101

    mdj101 New Member

    I don't have .htaccess as it's a windows machine.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    It works.

    If you require any specific support related to installation after purchasing, then it will be provided.
  7. Mike

    Mike XenForo Developer Staff Member

    The safe_mode check is coming from PHP directly:
    if (@ini_get('safe_mode'))
    $errors['safe_mode'] = 'PHP must not be running in safe_mode. Please ask your host to disable the PHP safe_mode setting.';
    I'm not sure why PHP info would say it's off while PHP itself would report it as on via ini_get() unless there's something else at play (directory specific configurations, different php.ini files/PHP binaries in use).

    That said, safe_mode doesn't even exist in PHP 5.4+ and anything lower than that isn't a supported version of the language. I'd strongly suggest using a newer PHP version if possible.
  8. mdj101

    mdj101 New Member

    Currently running

    PHP Version 5.2.17
  9. Mike

    Mike XenForo Developer Staff Member

    I would most definitely recommend upgrading to PHP 5.4 or newer.
    tyteen4a03 likes this.
  10. mdj101

    mdj101 New Member

    Just so you know I went ahead and installed XenForo even though I was getting the message above and it worked fine.

Share This Page