1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Switching Directories

Discussion in 'Troubleshooting and Problems' started by Savvy, Jul 25, 2011.

  1. Savvy

    Savvy Member

    So I want to change the location of my forum from www.gamerbb.net/forum to www.gamerbb.net - I tried moving all of the files from /forum into the public_html but it gives me an error. Is there more to it than what I'm doing?
     
  2. Floris

    Floris Guest

    Before you move, go to options in admin.php and make sure the board information is up to date.

    Also, moving doesn't include invisible files sometimes,
    .htaccess == invisible

    Make sure it's moved as well.

    And finally, make certain the internal_data/ and data/ dirs are still chmodded 777
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

  4. Savvy

    Savvy Member

    do you mean change this "require($fileDir . '/library/XenForo/Autoloader.php');"

    I'm trying it again, not sure exactly what error it was. I'm sure I will mess up so I'll post it in just a moment.

    404 Not Found

    The resource requested could not be found on this server!

    Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Do you have a portal mod installed?

    Your domain root is automatically loading http://www.gamerbb.net/forum/portal/

    You may need to update some other settings in the ACP, contact the mod author if necessary.
     
  6. Savvy

    Savvy Member

    It was a redirect, I think I may have figured it out.

    for some reason I get this when I tried to log in: http://www.gamerbb.net/login/login

    404 Not Found

    The resource requested could not be found on this server!

    Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

  8. Savvy

    Savvy Member

  9. Brogan

    Brogan XenForo Moderator Staff Member

  10. Savvy

    Savvy Member

    That's probably why. Floris mentioned it would be invisible. Is there a way to make it visible from the Cpanel?
     
  11. Brogan

    Brogan XenForo Moderator Staff Member

    Probably.
    I don't use cPanel though for browsing files and directories.

    There is an htaccess.txt file in the directory.
    Download it, rename it to .htaccess and ftp it back to your web root.

    Assuming of course you don't already have an .htaccess file in the root.
    In which case you will need to merge the contents.
     
  12. Savvy

    Savvy Member

    Crap, I'm at work and can't download a FTP client. :(
     
  13. Brogan

    Brogan XenForo Moderator Staff Member

    So just disable friendly URLs for now then until you can replace the file.

    This is what the base .htaccess file contains:

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data|js|styles|install) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
     
    Savvy likes this.
  14. Savvy

    Savvy Member

    I think I got it all worked out with the friendly URLs activated. :D
    Thanks for all the help... again. ;)
     
  15. Floris

    Floris Guest

    Glad to hear!
     
    Savvy likes this.

Share This Page