1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 super-admin unable to access closed board

Discussion in 'Troubleshooting and Problems' started by rwm1962, Jul 3, 2015.

  1. rwm1962

    rwm1962 Active Member

    I've 2 super-admin accounts on my new XF board. The 1st is the one set up on board creation & the 2nd is my imported admin account.

    I have set up the 2nd admin account as a super-admin via config.php.

    The 1st admin account can view the board when it is closed

    The 2nd admin account can access the ACP but is unable to view the closed board .

    How do I give the 2nd account permision to see the board when closed?

    Thanks
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    All administrators should be able to access the forum when it is closed, whether they are super or regular administrators.

    Try demoting the account from administrator and promoting it again.
     
  3. rwm1962

    rwm1962 Active Member

    Tried but didn't change anything.

    I promoted a regular test account to a regular admin & when logged in with that I can see the closed board.

    I've also ran clean up permissions.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Are you sure the member is an administrator in the ACP?

    Permissions don't apply in this case as it is related to the admin status.
     
  5. rwm1962

    rwm1962 Active Member

    Most definetly - in the administrators list that's only viewable by super-admins

    OK. I've also deleted the 2nd admin account as a superuser from config.php, demoted & promoted to regular admin. Tried different browsers. No joy

    However - Analysed & compared permissions with other test admin account & (assuming the results take into account the site is closed) can see has no permission to view, wheras the test admin does. Then compared permissions via 'user permissions' & the admin accounts have the same settings. The working test admin account has 'not set' for viewing permissions so I guessed was inheriting them but now know don't apply as per your post. The faulty admin account is set the same so I'd assumed it wasn't inheriting for some reason. I've set the user permissions on that individual admin account to 'allow' for viewing & it is now working. Don't know why that has worked given your reply.

    I though it may have something to do with it being an imported account but the working test admin account I created was also an imported test user.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    If there is no permission to view then they won't be able to view the forum at all, whether open or closed.

    You implied it was only related to the forum being closed.
     
  7. rwm1962

    rwm1962 Active Member

    The implication was due to the site being locked down for config prior to opening & going live, post import. But you are correct, if I put permissions back as they were the imported account, as admin or superadmin can't view the forum - open or closed. If permission are the same across the admins & don't apply anyway as per your post I'm baffled why the other admin accounts can view.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    The other admin accounts must have the view permission set elsewhere.

    You can use the permissions analyzer to determine that.
     
  9. Mike

    Mike XenForo Developer Staff Member

    There is a theoretical possibility of corrupted permissions. You may want to run the user cache rebuild and then go to <url>/install/ to rebuild the master data. This usually only happens from a bad add-on though.
     
  10. rwm1962

    rwm1962 Active Member

    I'll try that. Thanks.
     
  11. rwm1962

    rwm1962 Active Member

    Ok :oops:

    Thanks for your help. It's either been my mistake (likely) or something from the import.

    I'll 'fess up here in case anyone else has or creates the same problem.

    Comparing working & non working admin's 'user info' I discoverd the (primary) user group for the non-working admin account was 'administrative'. I have now changed that to match the other admins user info ie primary user group is now 'registered' & secondary user group is 'administrative.

    I can see why the permissions were not cascading correctly now.

    Apologies.
     

Share This Page