Sub-accounts by Waindigo [Deleted]

seebs

Member
Is there a setting I've missed to hide/not-reveal sub account ownership? And secondarily, do you know of anywhere other than the sidebar of member profiles that it's exposed?
 

Jon W

Well-known member
Is there a setting I've missed to hide/not-reveal sub account ownership? And secondarily, do you know of anywhere other than the sidebar of member profiles that it's exposed?
Not currently. I think that is the only place, although you need to make sure that the link can't be accessed at all so you might want to clear out the template waindigo_member_sub_accounts_subaccounts. Drop me a PM if you'd be interested in contributing to get this option added.
 

Epi

Active member
@Waindigo

when i click remove sub account the profile is still showing until i refresh sub account settings profile page.

Trying to re-add removed sub accounts again won't work either, it gives me this error: No valid users found.

edit one:
looks like they need email address entered before you can add them to your sub account.



Ajax isn't working for me though.

edit two:

tried with default theme and disabling most modules and ajax doesn't work. running 1.4.5 fyi.
 
Last edited:

NewGamePlus

Member
After installing and setting permissions, the sub-accounts page is just blank.

No server errors, just the page is blank.

upload_2015-4-6_23-6-34.png

What could this be?
 

Collapsible Myth

Active member
Receiving this server error after recently updating the addon.

ErrorException: Fatal Error: Class 'Waindigo_SubAccounts_Extend_XenForo_Model_User' not found -library/XenForo/Application.php(528) : eval()'d code:1
Generated By: Unknown Account, 22 minutes ago
Stack Trace
#0 [internal function]: XenForo_Application::handleFatalError()
#1 {main}
Request State
array(3) {
["url"] => string(45) "http://thelowerworld.com/index.php?liveupdate"
["_GET"] => array(1) {
["liveupdate"] => string(0) ""
}
["_POST"] => array(4) {
["_xfRequestUri"] => string(32) "/index.php?members/svetovid.160/"
["_xfNoRedirect"] => string(1) "1"
["_xfToken"] => string(8) "********"
["_xfResponseType"] => string(4) "json"
}
}

Also, the subaccount tab is not showing the "Remove" button.
 

seebs

Member
For what it's worth, I was able to hide the reveals of parent/sub accounts by messing with templates. I just did a check for whether the viewing user is an admin, but it could in theory be an option.

Downside, I have to turn the board off for upgrades, because upgrades can apparently revert the edit, and that can out people.
 
I'm attempting to use this in conjunction with Post as User and Login as User. Post as user seems to be associating sub-accounts properly so users can post as their sub-account from their main account, but login as user does not allow them to login to their sub-account from their main account. You mentioned before these should work in conjunction to give access to sub-accounts from main accounts. Is this a known issue?

Edit: Nevermind. It appears that 'Hiding Sub-Accounts' from the member list also hides it from the login list. Might be something to look into changing eventually, but its not a major issue.
 
Last edited:

Collapsible Myth

Active member
Lately been getting errors when someone is trying to create a new sub account.

2015-05-14_00-02-06.png

I've checked this on UI.X and in the XF default theme. Same results, members are unable to add new sub accounts.
 

Gossamer

Active member
Hi @Jon W. So, I'm still having trouble with subaccounts apparently adopting traits of the parent account. I've installed subaccounts on a brand new forum and this is still an issue.

All of the permissions seem to be correct, and the accounts in question have the appropriate usergroups assigned. The problem comes when I try to use the xen:helper ismemberof template code.

Code:
<xen:if is="{xen:helper ismemberof, $user, 3}">
             <img src="http://fracturerp.com/styles/fracture/themeImages/group_admin.png">
</xen:if>

My parent account is in the Administrator group (group 3) as a secondary usergroup. My subaccount is not. It's only in the registered usergroup currently as it's primary usergroup.

However, using that code again, both my parent admin account, and my subaccount end up with the same graphic.

Oh, nope, not just the "ismemberof" function. Just any secondary groups I try to pull.

I now have this in my message_user_info template:
Code:
{$user.username} - {$user.secondary_group_ids}

It outputs this:
Rani - 3
Bart Allen - 3
Mako - 6
Ralph Dibny - 6

This is what's in my actual database:
username
user_group_id secondary_group_ids


The "Rani" and "Mako" accounts are the parent groups. Bart Allen is subaccount to Rani and Ralph Dibny is subaccount to Mako.

Hi @Jon W. Have you had a chance to look at this bug yet? I've started using the usergroup banners for my forum's staff structure, so this bug is hitting us even harder now. The usergroup banner assigned to a parent account also displays on the subaccount.
 
Hi. I just installed the addon but when I go on my profile page their is no 'Sub accounts' link anywhere. Addon is installed and activated...
 

Gossamer

Active member
Hi. I just installed the addon but when I go on my profile page their is no 'Sub accounts' link anywhere. Addon is installed and activated...
Have you set the sub-account permissions for your usergroups yet? Once you've done that, then the link should appear.
 
Have you set the sub-account permissions for your usergroups yet? Once you've done that, then the link should appear.
Ah thank you very much. I did have two questions.

1. Can I make it so when sub accounts post it says who their main account is - without having to go to their profile?
2. I think sub accounts messages don't increase the main accounts post count. Can this be changed?

'Hide sub-accounts - If ticked sub accounts will not appear as members, only as aliases of the parents.' also doesn't seem to do anything.

Thanks!
 

Gossamer

Active member
Hi @Jon W. So, I'm still having trouble with subaccounts apparently adopting traits of the parent account. I've installed subaccounts on a brand new forum and this is still an issue.

All of the permissions seem to be correct, and the accounts in question have the appropriate usergroups assigned. The problem comes when I try to use the xen:helper ismemberof template code.

Code:
<xen:if is="{xen:helper ismemberof, $user, 3}">
             <img src="http://fracturerp.com/styles/fracture/themeImages/group_admin.png">
</xen:if>

My parent account is in the Administrator group (group 3) as a secondary usergroup. My subaccount is not. It's only in the registered usergroup currently as it's primary usergroup.

However, using that code again, both my parent admin account, and my subaccount end up with the same graphic.

Oh, nope, not just the "ismemberof" function. Just any secondary groups I try to pull.

I now have this in my message_user_info template:
Code:
{$user.username} - {$user.secondary_group_ids}

It outputs this:
Rani - 3
Bart Allen - 3
Mako - 6
Ralph Dibny - 6

This is what's in my actual database:
username
user_group_id secondary_group_ids


The "Rani" and "Mako" accounts are the parent groups. Bart Allen is subaccount to Rani and Ralph Dibny is subaccount to Mako.
Think I finally found a workaround for this, in case anybody else has the same issue.

The "Excluded Usergroups" option in the add-on options still works to force these secondary groups to no longer be inherited. The Sub-account inherits user groups from parent option is still broken (at the very least, it does not work properly with secondary usergroups). But you can get around this by manually excluding the usergroups in the same inheritance section.
 

Gossamer

Active member
Ah thank you very much. I did have two questions.

1. Can I make it so when sub accounts post it says who their main account is - without having to go to their profile?
2. I think sub accounts messages don't increase the main accounts post count. Can this be changed?

'Hide sub-accounts - If ticked sub accounts will not appear as members, only as aliases of the parents.' also doesn't seem to do anything.

Thanks!

1. Somebody can correct me if I'm wrong, but I don't think this is a feature right now.

2. This would be awesome and I'd love to see this as well. Hopefully that feature can be added.

And "Hide Subaccounts" removes them from view on the member list on my forum. I'm not sure it's supposed to do anything other than that.
 
Top