• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Style the Account Upgrades page?

Dynamic

Well-known member
#1
Hello,

I tried to wrap each upgrade in its own div via the upgrade manager but it did not work.

Is there any way to easily manipulate the way the account upgrades page looks? It is kind of hard to read the way it is set out.

Thanks.
 

Dynamic

Well-known member
#3
Hi @Brogan
I am trying to group certain upgrades and separate others. I would like them in a box with a different background colour. I tried putting them in <div></div> but it did not work, it just displayed the code.
 

Dynamic

Well-known member
#4
Anyone have any ideas on this? It will not support even basic html tags like <b></b> etc. It simply displays the code instead.
 

Russ

Well-known member
#5
Anyone have any ideas on this? It will not support even basic html tags like <b></b> etc. It simply displays the code instead.
There's a thread here:

http://xenforo.com/community/threads/jake-subscription-conditional.36370/

and here:

http://xenforo.com/community/threads/user-upgrade-images.34828/

With some info on styling it, I did group the upgrades in their own category by removing the default code and putting conditionals like this:

http://xenforo.com/community/threads/jake-subscription-conditional.36370/#post-414095

Not sure how many upgrades you have though...
 

Dynamic

Well-known member
#6
Hi @Russ,

Thanks for that. I think that is a bit much for what I am trying to do. For example, let's say I want some of the text to display as red in the description. It says html is allowed, so I would assume if I type in <span style="color:#ff0000;">something here</span> in the description box, the text will show up as red. But it does not. It just displays the html tags and code.
 

Russ

Well-known member
#7
Hi @Russ,

Thanks for that. I think that is a bit much for what I am trying to do. For example, let's say I want some of the text to display as red in the description. It says html is allowed, so I would assume if I type in <span style="color:#ff0000;">something here</span> in the description box, the text will show up as red. But it does not. It just displays the html tags and code.
Sorry I read you wanted to split it into groups, I just tested and it works:

test1.png test2.png

I would double check your HTML on that class and make sure it's not being overwritten by some other color, possibly with an !important
 

Dynamic

Well-known member
#8
hmmm, strange. For me it displays "<span style="color:#ff0000;">something here</span>" in the description. So it does not just display "Something here" as I would assume it would. It displays the whole thing.
 

Mike

XenForo developer
Staff member
#9
Are you actually running 1.2? As noted, this was changed in 1.2 -- the behavior you're explaining makes it sound like you're running 1.1.
 

Dynamic

Well-known member
#11
Sweet. I'll send him a message so he can take a look at the problem. Can't disable the addon unfortunately, it gets used too much. Thanks for the help guys :)