XF 2.2 Strange permission issue with not being able to post anywhere even as admin

Frode789

Well-known member
Permission problem.
It has worked well in the last months, but suddenly I was trying to post a dummy post to test some new functionality, and now I suddenly was unable to post (as admin even) in my forum nodes. All nodes, in fact.
I was like "what the heck is going on..."
I haven't installed anything else major lately apart from SEO addon, but that was some time back. (though I don't remember if I had tried to post after that or not), but not sure what the problem is. Seems strange that the addon would have anything to do with a permission problem.. Hence posting here.

I check permission and they all now stand on "inherit". (they did not before I think). Anyway, I change them as I like (yes on posting permissions etc) and try again. Still unable to post.

When trying to make a new thread:
1649514087476.png


I can create new node. Set literally All permissions to yes.
Still can't post.

Any obvious thing in regards to permissions that I have missed?
 

Brogan

XenForo moderator
Staff member
XF code wouldn't randomly do this.

Something must have changed, or a third party add-on must be involved.

Analyse the permissions for your account for a specific node you can't post in.

Disable all add-ons and try posting.
 
Top