• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Browser issue Strange Indent while editing CSS

Russ

Well-known member
#1
So I wish I had a better way to replicate this... I ran into this the other day and didn't think much of it.

Then happened again last night a couple times.

What would happen I'd be using FireFox (22.0 Windows 7) browsing my dev site and have extra.css open in another window.


Once I'd find a snippet of code I'd browse to extra.css, Ctrl-F for it in case it was already in there and the indent would disappear in the found code would remove, so the css would shift to the left. Thinking I hit something I hit undo but it doesn't undo the indent it undoes the last edit I made.

Once it happened again I realized if I click anywhere on the editor the missing indent would fix it self.


It's minor, but annoying, and more annoying I'm having trouble reproduce it.


EDIT** To be clear the indent only removed on the one line below the found code, not the entire document.
 

Lisa

Well-known member
#2
I can confirm this happening, noticed it myself the other day. Can backspace and remove the indent, but go to the next line and we're indented :D
 

Mike

XenForo developer
Staff member
#3
That sounds like a weird redraw issue, but unfortunately I'm really not understanding the report exactly.

Anyway to show screenshots or videos of it in action?
 

Russ

Well-known member
#4
That sounds like a weird redraw issue, but unfortunately I'm really not understanding the report exactly.

Anyway to show screenshots or videos of it in action?
I'm trying to reproduce it and of course can't, but it's happened like 5 times since 1.2 update.

Literally just random indents being removed, clicking in the editor window again re-does the indent.

I'll try to see if I can't narrow down the steps to get it again
 

Russ

Well-known member
#5
It just happened again, but it's completely random, I know the screenshots don't tell you much but here they are anyway:

Used control-F to find ".razerLogo" when I found the text the css indent beneath it was removed
bug1.png


Clicking anywhere on the template redoes the indent. bug2.png

I should note too... when I find the results I see the indent quickly disappear.
 

Mike

XenForo developer
Staff member
#6
I honestly don't have a clue why this would happen. This seems to be something that's happening entirely in the browser. The fact that clicking in it fixes it makes me think it's a draw bug. I don't think there's really much that we can do about it.
 

Russ

Well-known member
#7
I honestly don't have a clue why this would happen. This seems to be something that's happening entirely in the browser. The fact that clicking in it fixes it makes me think it's a draw bug. I don't think there's really much that we can do about it.
I know this was marked a browser issue, I finally managed to get a video of it doing it a lot. Just figured I'd post it.