• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 2.0 StopForumSpam question

#1
For the most part, we get warnings from StopForumSpam when a new user registers and is flagged. This is our setup:

Capture2.JPG

How then did this guy flag no warnings but a manual check on Cleantalk:
https://cleantalk.org/blacklists

Resulted in this: IP & e-mail Details for 196.207.73.135
Capture.JPG
 
Last edited:

Mike

XenForo developer
Staff member
#3
Do you have any add-ons that may do anti-spam stuff? Given that you mention CleanTalk, I assume you're running their add-on, so if they're not handling the spam trigger logging information as expected, it's possible nothing will be logged there.
 
#4
We only use the StopForumSpam that came with our XF license. We use Clean Talk as a non-add on backup program.
The only add-ons we have are as follows:
Capture.JPG
 
#5
Maybe the answer is found in these threads:
https://xenforo.com/community/threads/spam-management-not-working-as-expected.99926/
and:
https://xenforo.com/community/threa...block-spammers-without-false-positives.70415/

I changed the "Only count flags recorded at least this many times:" from 5 to 2. This way if the username is the 1st flag, they should be detected as a spammer from their SFS check by e-mail or IP address as the 2nd flag? Correct or do you think changing to 2 will reject too many legitimate applicants?
 

Mike

XenForo developer
Staff member
#6
That option controls how quickly you treat a flag as a spam trigger. It doesn't control what an individual flag means, so that won't do what you're expecting.

However, if SFS did trigger this, even on username, there should be a spam trigger log entry (it really should be showing on this page). Is there anything showing up in that log? If there's nothing there, just to confirm, you don't have manual approval for users enabled do you?
 
#7
We do have manual approval for users checked as we prefer to do it that way for all new applicants. However when SFS is triggered we get a warning....
Here's our settings:
------------------------------------------------------------------------------------------------------------------------------
Capture.JPG
------------------------------------------------------------------------------------------------------------------------------

Here's what we get when SFS catches them first:

Capture.JPG
 
#8
The spam trigger log is apparently working to some degree, because as of this morning there are 206 entries from 10/6/17 to today. Don't know how to see more, but doesn't seem necessary.

Capture.JPG

The user in the first post who tried to join us yesterday at 9:46am did not trigger a hit on the SFS log. That's why we approve manually in case they slip through the cracks.
 

Mike

XenForo developer
Staff member
#9
We do have manual approval for users checked as we prefer to do it that way for all new applicants.
Well that's why the user is in the manual approval queue then. Every user that registers will end up there, regardless of whether they hit any spam triggers (unless they hit enough to cause the registration to be automatically rejected).

If you don't see a spam trigger log, then there's no spam rules that have been hit.