Browser issue Sticky menu... stuck?

Affected version
2.0 Beta

RobParker

Well-known member
I've had this happen a couple of times on my iPhone but it's not that easily reproducible.

The sticky menu jumps to the middle of the screen and stays there.

IMG_5266.PNG
 

Kier

XenForo developer
Staff member
I'm assuming that's Safari, but are you able to say what version specifically, and any possible steps to reproduce the issue?
 

RobParker

Well-known member
Yep it's Safari on an iPhone 7+ running iOS 10.3.1.

It's hard to reproduce but scrolling/swiping up/down fast seems to be the trigger. I had it happen a couple of times on the alpha and now again just.

It persists like that across pages as well (had to close the tab to fix it).
 

Kier

XenForo developer
Staff member
I haven't seen this since iOS 11, so I think it's fairly safe to assume it's a Safari bug that has now been fixed.
 

RobParker

Well-known member
We've just upgraded our live site and several users reporting seeing this happen. This is happening on Edge though, not iOS.

Our live site also uses a style by @Russ / @Steve F but given we saw it originally happen on the default style I assume it's not being caused by anything they've done and it's something in the XF core.

1522502168991.png
 

Steve F

Well-known member
I would still try to rule out the style Rob, make a default style and let them test. I can say we do not do anything special in the nav though. Also might a be good idea to check the browser console for any errors.
 

Chris D

XenForo developer
Staff member
User agent details from the affected users would be useful too. This will help us identify the affected Edge versions and detect them in code if we need to make any special cases.

Just Google “what is my user agent”.
 
Top