Starting a second forum - questions

Alvin63

Active member
Got a feeling it's a DO issue, as I recently had to redo the VPS and it got a new IP number. Odds are some spammer had it before me. Guess I need to do some research.
So, looks like your AV is giving a false positive.
View attachment 274875

And yep, it's that very "illustrious" Norton AV "Safe Web"... the AV that can't get out of it's own way!

View attachment 274876
Thanks for letting me know :) I thought it seemed strange being a link from here from a well known member.
 

Alvin63

Active member
One of your CSS edits is invalid.
Ok. The only one I've got is to reduce the size of the header in the header/logo row. It's

height: 85px;



I also have this in extra.less

.p-header-logo {
margin-left: auto;
}

To centre the logo. Those are the only two edits I've done.
 

webbouk

Well-known member
Copy the contents of your extra.less to Notepad (or similar) then 'Revert' the file back to it's original form.
Test your forum and if it works insert the copied content back into the file, an edit at a time selecting 'Save' then recheck your forum.
 

Alvin63

Active member
Forum is working fine and the error has gone now since I deleted it. But will do that yes. Is there any different or better way to reduce the height of the header?

Edit - I meant is there any different or better way to centralise the logo? That's the bit that's in extra.less
 

Alvin63

Active member
You want to see several of Bob's add-ons in action along with the Media Gallery and RM, feel free to stop by the site in my sig. You can access all of it as a guest (can't enter any data though).
Your forum looks fantastic :) Did you design it all or get someone to customise it? I'm struggling with a noddy logo at the moment. It's ok but ...
 

webbouk

Well-known member
Forum is working fine and the error has gone now since I deleted it. But will do that yes. Is there any different or better way to reduce the height of the header?

Edit - I meant is there any different or better way to centralise the logo? That's the bit that's in extra.less

Add this to extra.less

// Center Logo .p-header-logo { margin-left: auto; margin-right: auto; }
 

Tracy Perry

Well-known member
Yay! Did you report it to them?
yep... submitted it to them.

Your forum looks fantastic :) Did you design it all or get someone to customise it? I'm struggling with a noddy logo at the moment. It's ok but ...
thanks... the base style is a PixelExit one (@Russ does a great job), but is one of their older ones but the best I found to fit what I wanted. I've modified it "slightly" :sneaky: to fit more inline with what the topical area is.
The logo, even somewhat corny in appearance, was created by me. I do have to admit that it turned out looking rather nice on the back of some t-shirts I had done. I changed the text up somewhat to make it more compact, but the next batch will use merge instead of join. I went with what the better 1/2 suggested instead of my first instinct. The sweatshirts didn't turn out as nicely as they kept the text more rectangular in location than spread out like on the t-shirt.

IMG_1143.JPG
 

Alvin63

Active member
I am struggling with my logo. It's ok but looks a bit like there's something missing. Did it in a logo creation program. And it looks absolutely terrible in mobile view.

Does Russ do logo design?
 

Tracy Perry

Well-known member
I am struggling with my logo. It's ok but looks a bit like there's something missing. Did it in a logo creation program. And it looks absolutely terrible in mobile view.

Does Russ do logo design?
Yes, @Russ, the last time I checked, provided many services. Honestly, if you have the ka-ching (which I do not since I'm retired on a fixed income) it would be well worth your time & money to contact him. PixelExit (edited, to many Pixel softwares I deal with) does an excellent job and every one of their custom styles I have seen has been beyond impressive.
 
Last edited:

Alvin63

Active member
No I don't have the ker-ching! I used one of Pixel exits styles on my other forum but designed the current one myself. Just straight forum but colour adustments. But I could do with a good logo/top bar.
 

Tracy Perry

Well-known member
No I don't have the ker-ching! I used one of Pixel exits styles on my other forum but designed the current one myself. Just straight forum but colour adustments. But I could do with a good logo/top bar.
Exactly the position I'm in. I'm a purely self-supported site and am a fixed income. I do my site for the love of the topic. I HAVE been blessed by being around for awhile and having some VERY good associates/friends that are familiar with the aspect of admin/customization. @Russ being one of them. It's one of the reasons that I have, and will continue, to highly recommend PixelExit.... there are few that have been around as long as they have and are as dedicated to XF as they are. My current style is a simple example of what simple tweaks can take their stuff to.

One thing you might do is (if you aren't already) join The Admin Zone and see if anyone there is interested in creating you a nice logo. Some of the folks that work over there are very reasonable.
 
Last edited:

Alvin63

Active member
Ok so my forum is getting going before I've finished it! Word has got out. So I'm madly trying to get everything sorted and ready. It looks ok (apart from the logo which doesn't show up well on mobile view).

But I seem to remember there are various things I need to set up in the admin panel re email and allowing Google searches and bots etc. Is that right? Or is email just set up to go? Have had one email issue resolved by the server.
 

Alvin63

Active member
Under SEO there's an option to tick using friendly URL's to get rif of the "index.php?" in the web address. Should I tick that? Underneath it says

"If you enable this option, the links generated by the system will not include "index.php?". However, to enable this, mod_rewrite must be available and an appropriate .htaccess file (or the equivalent for your web server) must be in place."

I seem to remember there is an .htaccess file in the forum software on the server so assume it's ok to tick that.
 

Mr Lucky

Well-known member
Under SEO there's an option to tick using friendly URL's to get rif of the "index.php?" in the web address. Should I tick that? Underneath it says

"If you enable this option, the links generated by the system will not include "index.php?". However, to enable this, mod_rewrite must be available and an appropriate .htaccess file (or the equivalent for your web server) must be in place."

I seem to remember there is an .htaccess file in the forum software on the server so assume it's ok to tick that.
You may need to activate the .htaccess by removing the suffix: .txt
 

Alvin63

Active member
Ok - could you explain that please :) Where is the suffix .txt that I move? In the server file manager? Also I had a look on google console and it suggests adding some code to the forum to verify the site. Is that a good idea or not? Don't think I did that before - I got "seen" by google via google ads.
 

Alvin63

Active member
Also - Favicon. I find this confusing. Real favicon generator says to extract the files within the root of your website and then insert code into the head of web pages. Sounds very complicated. I think last time I just had a 16 x 16 ico and uploaded it to the website on the server. Now it seems to give you all kinds of favicon sizes for different media and install the lot in your website server.

I just want to keep it simple! I did make a favicon in favicon io - but once downloaded it was a .png instead of an io. When I converted it, it looked very fuzzy. Favicon io also downloads various different sizes but only one is an io and that's too big.
 

Alvin63

Active member
Ok I have sorted my favicon. I found it all far too complicated with different favicon sizes in a file to upload to the root and code to put on each page but in the end one of the icons in the download was a 32 x 32 ico file so I just uploaded that one to the server and it worked. Seems hard to just get a 16 x 16 ico file made on its own these days.

If anyone's interested I used this site and just used the one 32 x 32 ico file from the download and forgot the rest and the code it suggested etc.

 

Alvin63

Active member
I've semi sorted the email with the host. Still haven't sorted the index.php on the web address yet as not sure what to do.
 
Top