• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Spoiler already expanded

#1
The spoiler tag works ok, everytime appears normal (hidden) and when click it expands.... everything ok... but when I include ad4game.com advertisements on "ad_above_top_breadcrumb"... all the spoilers appear already expanded and when I click on "see-hide" I'm redirected to forum home page....

I don't know if its ad4game problem or if it's Xenforo's includes spoiler with advertisement scripts...
 

Mike

XenForo developer
Staff member
#2
This would generally indicate there's a conflict from the advertising scripts. You should look at the JS console to identify the underlying cause.
 
#5
Code:
XenForo.activate(%o) [object HTMLDocument] xenforo.js:221
"Invalid App Id: Must be a number or numeric string representing the application id." sdk.js:56
"FB.getLoginStatus() called before calling FB.init()."
nothing more...
 

Mike

XenForo developer
Staff member
#8
There is a JS error:
Uncaught TypeError: undefined is not a function
This is likely through the ad manipulating something unexpectedly. It also doesn't happen every time -- it appears to be specific to the type of ad. Non-Flash ads seem to work correctly.

Unfortunately, this is something you'd need to talk to your ad provider about.
 
#9
Ok, I already contacted ad4game

Keep this thread open if I need to say/ask something more.

Thanks.

(and the text editor also disappear)
 
Last edited: