1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Speed of xenForo vs vBulletin 3

Discussion in 'General XenForo Discussion and Feedback' started by vord, Oct 16, 2013.

  1. vord

    vord Member

    Those of you who moved over from vB3 to xenForo how does the speed of page loading compare for you?

    For me vB3 on my server is snappy quick (0.5 seconds) , xenForo on this server reasonable (1.0 seconds) and xenForo on my server a bit disappointing (closer to 2 seconds). I reckon my visitors are going to notice and will ask why the heck I want to change over.

    Is this a typical experience or am I doing something wrong?

    I'm running a windows 2008 dedicated server with a good host on fast cgi with next to no load. I'd rather be running linix but have something else on there that requires windows so would need another server if linux is necessary for xenforo.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    The database structure (table engines) is different.
    You may need to do some server tuning.

    How is my site?

    http://cliptheapex.com/
     
  3. Alteran Ancient

    Alteran Ancient Well-Known Member

    Is that IIS with PHP via FastCGI? Your results are going to vary greatly from server configuration to server configuration. With Windows, though, you do have the option of using Apache if you aren't already doing so.

    On paper, xenForo should be quicker than vBulletin 3 before caching or accelerators even come into the question. You should be able to use APC or XCache on Windows as an "opcode" cache for PHP. You should see definite improvements by doing this.
     
  4. Digital Doctor

    Digital Doctor Well-Known Member

  5. z3r010

    z3r010 Member

    I was having slowness issues on a Windows box with Xenforo a few days ago, it turns out Windows didn't like localhost being used in the config.php file, once I switched it to 127.0.0.1 the site speeded up massively.
     
    vord and Digital Doctor like this.
  6. vord

    vord Member

    Your site is super speedy snappy Brogan.


    Aaaaaaaaaaaaa. I remember that one now. That's done the trick!
    Thanks z3r010. I can do the change over now.
     
  7. z3r010

    z3r010 Member

    Also if your not using Wincache you should give it a go, that knocked about a 3rd off my page load time on my Window 2012 box.
     
  8. vord

    vord Member

    So excited to have this lovely software being super snappy speedy! Fecking windows!

    Will talk to the host about Wincache. I know he had a lot of trouble with the php based caches recommended by vB3 (APC and Memcache) and don't know where we are on caching at the moment. Do you prefer wincache to the zend cache that can be evoked in the config?

    What were the other tips for super speedy you had in mind Brogan?
     
  9. Mike

    Mike XenForo Developer Staff Member

    I believe with "localhost", Windows will attempt to use IPv6 :):1) to connect and then silently fallback to IPv4 (127.0.0.1) if it fails (which presumably it is) -- this likely depends on your "hosts" file configuration. Good catch though.
     

Share This Page