1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Spam & 1.2

Discussion in 'General XenForo Discussion and Feedback' started by MikeMpls, Jul 15, 2013.

  1. MikeMpls

    MikeMpls Well-Known Member

    It's beginning to look as though one of the moving-image captchas will still be needed to keep spammers at bay in 1.2. Both my 1.2 forums were new, so it took a while for the spammies to find them, but they have arrived.

    I reported & deleted two clear cases of registration spam. One of these would have had two hits in the StopForumSpam DB (which was configured) but it wasn't even moderated.

    Overall this does appear to be XF's best anti-spam effort yet, but it's still falling a bit short, and I can't afford to spend potentially several hours a day cleaning this stuff up, so it's back to the captchas that require the user to move an image to complete his post/comment/registration.
     
  2. Mike

    Mike XenForo Developer Staff Member

    Well, there's a bug with the SFS stuff in the current beta...

    But have you configured other elements like Akismet or common spam phrases?
     
  3. cmpe

    cmpe Active Member

    About how long did it take since you launched the forum?

    I added 5 very unique questions instead of using reCAPTCHA and had 0 spam registrations so far. Only been two weeks though.
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    I believe I've seen a total 3 spam posts in the last few weeks here. 1.2 really has best-in-class spam management tools. As Mike said, you should take advantage of all the tools available to you.
     
  5. MikeMpls

    MikeMpls Well-Known Member

    Everything is configured/enabled. There is nothing further for me to "take advantage of".

    If spammers are getting through and registering, I would stop short of calling it "best-in-class spam management tools". We achieved better w/ 1.1. releases and addons, although 1.2.0 and even 1.1.5 do pretty well on their own -- they just need that Captcha that automation hasn't yet solved. I do like being able to chuck most of the addons.

    A bug in the SFS check would explain the one that I saw this morning -- no post or profile spam yet but obviously ready to go, & should have failed 2 SFS tests! If it's in the bug forum, I'll track it & try to note what happens after I upgrade to the fix (right now one site is on Beta 5, the other on Beta 4).
     
    Last edited: Jul 16, 2013
  6. MikeMpls

    MikeMpls Well-Known Member

    They started appearing about 3 weeks after I created them. In the past my rule of thumb was 2 weeks.

    With one 1.1.5 forum it got to the point after a couple that I was was getting a large number spam guest posts & several spam registrations daily. Nothing on 1.2.0 has been that bad yet.

    I operate > a dozen XF sites. Q&A captcha's are not an effective use of my my time, since they are inevitably solved, and when they are solved the Q&A goes into Xrumer's database to be shared with all their fellow spammies. I am not going to spend a significant amount of time every day changing & updating the Q&A captcha's.
     
    Last edited: Jul 16, 2013

Share This Page