sonnb - XenGallery (XenForo Gallery)

sonnb - XenGallery (XenForo Gallery) [Paid] 2.6.7

No permission to buy ($40.00)

doublespaces

Well-known member
So this means I don't need the XFMG? Does this mean the little camera icon on the toolbar will be gone? Also, can this do watermarks?
 

doublespaces

Well-known member
Not sure what you mean. If you have this addon then you don't need XFMG, that is correct. You wouldn't run both of them at the same time.


The above toolbar is what I was referring to. Is that icon simply gone or does XenGallery do something similar? Also, can XenGallery do watermarking on uploaded photos like XFMG?
 

dknife

Well-known member
The above toolbar is what I was referring to. Is that icon simply gone or does XenGallery do something similar? Also, can XenGallery do watermarking on uploaded photos like XFMG?
That icon is for XFMG, Sonnb XenGallery has different icons. They're 2 different plugins that provide media gallery functionality to XenForo with some differences between them. It's up to you which you'd like to use but you wouldn't have them both active.

Sonnb's XenGallery has watermarking.
 

doublespaces

Well-known member
That icon is for XFMG, Sonnb XenGallery has different icons. They're 2 different plugins that provide media gallery functionality to XenForo with some differences between them. It's up to you which you'd like to use but you wouldn't have them both active.

Sonnb's XenGallery has watermarking.
Thank you for the response. I understand the icon is for XFMG, but does XenGallery do something similar to that? You said it does have icons so that kind of answers my question.

If it also does water marking, I may make this switch until I move to XF2.
 

snoopy5

Well-known member
I guess that you mean "When the update for XF 2.0 will be released?". I am working on it but I do not have a clear plan yet. You know, we need to change all the things to adapt.
Dear Sonnb,

I am one of the early customers of your gallery addon. I purchased it in 2013 with its version 1.x when XMG was not yet merged with XF. I do not regret that decision.

Your Xengallery is so much better for photography oriented forums vs. XMG. It is not only cheaper than XMG, it offers even after 5 year years now still more and better features for photo-centric-communities. The video upload features are also good.

Please keep this focus on photography and photographers also for the new XF2.0 (Xengallery 3.x) compatible version in 2018!
 
Last edited:

dknife

Well-known member
How do I get my gallery to look like this one? With the category list first and the navigation sidebar on the left? It looks so much nicer than the jumbled mess that mine is.

https://www.boatdesign.net/gallery/
uhh that's XF Media Gallery, the official plugin from XenForo. SonnB's XenGallery is a different plugin.

For what it's worth SonnB's thumbnail method and "jumbled mess" (which is actually a really good masonry packing system) is IMO far superior to XFMG square thumbs and poor cropping method and I really miss that.
 

mauzao9

Well-known member
Yeah I'm annoyned default XFMG type of navigation and browsing isn't lke this gallery plugin, that aims more at how Facebook does it and that is a quick and easy way to browse without having to load every picture page the old fashion way.
 

BobHarbison

Active member
uhh that's XF Media Gallery, the official plugin from XenForo. SonnB's XenGallery is a different plugin.

For what it's worth SonnB's thumbnail method and "jumbled mess" (which is actually a really good masonry packing system) is IMO far superior to XFMG square thumbs and poor cropping method and I really miss that.
OK, well I'm brand new to XF and couldn't tell which it was.

Ignoring the image display bit, what really matters to me is the category listings sidebars and on the top of the first page. Is that possible to do in Xengallery? I just find the gallery seems hard to navigate, as the categories aren't obvious when you first look at it, it makes it look like "here's every photo!" is the only option.
 

Jordyn

Formerly EvilSS
OK, well I'm brand new to XF and couldn't tell which it was.

Ignoring the image display bit, what really matters to me is the category listings sidebars and on the top of the first page. Is that possible to do in Xengallery? I just find the gallery seems hard to navigate, as the categories aren't obvious when you first look at it, it makes it look like "here's every photo!" is the only option.
I get where you're coming from, this gallery lacks a visible categories list using desktop/laptop, although the drop down categories are pretty easy seen. But, comparing xfmg and xengallery using mobile, categories are easy seen at the top using xengallery, where xfmg you have to scroll to the bottom to see the categories list. If you display a lot of photos on the first page using xfmg, then you have some scrolling to do :D

I use both gallery's, i like both gallery's, but the only issues i have with xfmg is, now and then a photo or video goes missing out of thin air. Oh and you cant manage albums in the admincp like xengallery. If i could use 2 versions of xengallery i would. xengallery is for me the better gallery for mobile. I moved from vb3 to xf because of xengallery. But then, like you found that the categories list isn't displayed as well as xfmg, so i bought xfmg for a separate niche and made it the primary gallery. xengallery as offtopic and xfmg as main niche. I wish now i didn't do this, all because of the categories list. Now im stuck with it this way.

Theres got to be away to display a better categories list using xengallery, i just never looked into it really as buying xfmg was the easy way out. What a mistake. Good luck for what ever path you go down.
 

ActorMike

Active member
Is there a way to just send one email when someone adds like 10 photos to a gallery? I got 20 emails today for each photo someone added to their gallery! This is too much! Only need one email per day per gallery @sonnb

Is there a setting to change this? If not, surprised nobody has said anything yet about this issue. Thanks for listening.
 

oO5 Dynasty

Well-known member
1526505539020.png
Problem with uploading!
I choose an image and after a few sec, the image disappears and it then says no file chosen. I am running version 2.6
 

oO5 Dynasty

Well-known member
After loking into this issue of me not being able to upload images anymore i found an error that keeps coming up.

Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Unknown column 'extension_unencoded' in 'field list' - library/Zend/Db/Statement/Mysqli.php:77



Code:
#0 /home/deadcl6/public_html/oo5dynasty.com/user/library/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('INSERT INTO `so...')
#1 /home/deadcl6/public_html/oo5dynasty.com/user/library/Zend/Db/Adapter/Mysqli.php(381): Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), 'INSERT INTO `so...')
#2 /home/deadcl6/public_html/oo5dynasty.com/user/library/Zend/Db/Adapter/Abstract.php(478): Zend_Db_Adapter_Mysqli->prepare('INSERT INTO `so...')
#3 /home/deadcl6/public_html/oo5dynasty.com/user/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `so...', Array)
#4 /home/deadcl6/public_html/oo5dynasty.com/user/library/XenForo/DataWriter.php(1638): Zend_Db_Adapter_Abstract->insert('sonnb_xengaller...', Array)
#5 /home/deadcl6/public_html/oo5dynasty.com/user/library/XenForo/DataWriter.php(1627): XenForo_DataWriter->_insert()
#6 /home/deadcl6/public_html/oo5dynasty.com/user/library/XenForo/DataWriter.php(1419): XenForo_DataWriter->_save()
#7 /home/deadcl6/public_html/oo5dynasty.com/user/library/sonnb/XenGallery/Model/PhotoData.php(400): XenForo_DataWriter->save()
#8 /home/deadcl6/public_html/oo5dynasty.com/user/library/sonnb/XenGallery/ControllerPublic/XenGallery/Photo.php(439): sonnb_XenGallery_Model_PhotoData->insertUploadedPhotoData(Object(sonnb_XenGallery_Model_PhotoUpload), Array)
#9 /home/deadcl6/public_html/oo5dynasty.com/user/library/XenForo/FrontController.php(351): sonnb_XenGallery_ControllerPublic_XenGallery_Photo->actionDoUpload()
#10 /home/deadcl6/public_html/oo5dynasty.com/user/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#11 /home/deadcl6/public_html/oo5dynasty.com/user/index.php(13): XenForo_FrontController->run()
#12 {main}

Code:
array(3) {
  ["url"] => string(51) "http://oo5dynasty.com/user/gallery/photos/do-upload"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(6) {
    ["_xfToken"] => string(8) "********"
    ["hash"] => string(32) "e7565ed490a9293669441fcb6dcfe22f"
    ["album_id"] => string(1) "0"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(9) "json-text"
    ["_xfUploader"] => string(1) "1"
  }
}



(anonymous) @ xenforo.js:336
/user/gallery/photos/do-upload Failed to load resource: the server responded with a status of 500 (Internal Server Error)
 

sonnb

Well-known member
Is there a way to just send one email when someone adds like 10 photos to a gallery? I got 20 emails today for each photo someone added to their gallery! This is too much! Only need one email per day per gallery @sonnb

Is there a setting to change this? If not, surprised nobody has said anything yet about this issue. Thanks for listening.
I do believe that it only sends 1 if they add 20 photos at once. But not possible if separately. Like in FB.

After loking into this issue of me not being able to upload images anymore i found an error that keeps coming up.

Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Unknown column 'extension_unencoded' in 'field list' - library/Zend/Db/Statement/Mysqli.php:77



Code:
#0 /home/deadcl6/public_html/oo5dynasty.com/user/library/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('INSERT INTO `so...')
#1 /home/deadcl6/public_html/oo5dynasty.com/user/library/Zend/Db/Adapter/Mysqli.php(381): Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), 'INSERT INTO `so...')
#2 /home/deadcl6/public_html/oo5dynasty.com/user/library/Zend/Db/Adapter/Abstract.php(478): Zend_Db_Adapter_Mysqli->prepare('INSERT INTO `so...')
#3 /home/deadcl6/public_html/oo5dynasty.com/user/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `so...', Array)
#4 /home/deadcl6/public_html/oo5dynasty.com/user/library/XenForo/DataWriter.php(1638): Zend_Db_Adapter_Abstract->insert('sonnb_xengaller...', Array)
#5 /home/deadcl6/public_html/oo5dynasty.com/user/library/XenForo/DataWriter.php(1627): XenForo_DataWriter->_insert()
#6 /home/deadcl6/public_html/oo5dynasty.com/user/library/XenForo/DataWriter.php(1419): XenForo_DataWriter->_save()
#7 /home/deadcl6/public_html/oo5dynasty.com/user/library/sonnb/XenGallery/Model/PhotoData.php(400): XenForo_DataWriter->save()
#8 /home/deadcl6/public_html/oo5dynasty.com/user/library/sonnb/XenGallery/ControllerPublic/XenGallery/Photo.php(439): sonnb_XenGallery_Model_PhotoData->insertUploadedPhotoData(Object(sonnb_XenGallery_Model_PhotoUpload), Array)
#9 /home/deadcl6/public_html/oo5dynasty.com/user/library/XenForo/FrontController.php(351): sonnb_XenGallery_ControllerPublic_XenGallery_Photo->actionDoUpload()
#10 /home/deadcl6/public_html/oo5dynasty.com/user/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#11 /home/deadcl6/public_html/oo5dynasty.com/user/index.php(13): XenForo_FrontController->run()
#12 {main}
Could you check if you installed the Video Upload add-on correctly? Or if you do not use it then uninstall it. This field is added by Video Upload add-on.

Code:
array(3) {
  ["url"] => string(51) "http://oo5dynasty.com/user/gallery/photos/do-upload"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(6) {
    ["_xfToken"] => string(8) "********"
    ["hash"] => string(32) "e7565ed490a9293669441fcb6dcfe22f"
    ["album_id"] => string(1) "0"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(9) "json-text"
    ["_xfUploader"] => string(1) "1"
  }
}



(anonymous) @ xenforo.js:336
/user/gallery/photos/do-upload Failed to load resource: the server responded with a status of 500 (Internal Server Error)
 

oO5 Dynasty

Well-known member
I do believe that it only sends 1 if they add 20 photos at once. But not possible if separately. Like in FB.
So i uninstalled the video add-on and also uninstalled the gallery add-on. I then did a reinstall of the gallery add-on and its still not working. Can you loginto my site and try to upload an image.
 
Top