1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Some problems

Discussion in 'Troubleshooting and Problems' started by ThunderBird2, Apr 15, 2013.

  1. ThunderBird2

    ThunderBird2 Member

    Hi guys,

    As a newbie, I am getting frustrated with some issues (i.e Connection timed out daily, Email Options/SMTP, .htaccess, few steps) ???

    Nobody is willing to help, come on guys! :(
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    What are the problems?

    Providing some details would be useful.
     
  3. Shelley

    Shelley Well-Known Member

    I remember this issue I experienced with setting the Email Transport Method thing to SMTP and for some reason whenever I created a post it would time out all the time. Unsure whether that sheds any useful light or the OP is experiencing the same issue but it sounds like a server issue not a xenforo one. I could be wrong however.
     
  4. ThunderBird2

    ThunderBird2 Member

    1) Connection Timed out- my xenforo site and ACP is mostly down, it says connection timed out. I even contacted my shared host provider namecheap to fix this issue, however, it doesn't stop this problem. I still face my site down now and everyday, how to fix it something with xenforo hosting provider? any advice if you know similarly.

    2) Email Option - I have tried to set up via using SMTP from Email Transport Method and my hosting properly. My visitor didn't get email confirmation. I have review this thread, it didn't successful so far from five hours efforts to fix it last night. PM me if you want screenshot. Though My site is still down, I can't do anything.

    3) .htaccess - I put extra security method, read this thread, and put .htpasswd. I don't understand why it didn't recognize username and password when I typed it .

    These are few steps that need to be fix with your help. I don't know which was wrong on xenForo or hosting provider.
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    Only your host can resolve hosting issues.

    See this for emails being marked as spam: http://xenforo.com/community/resources/dealing-with-spam-filters.366/

    If the user name and password aren't being recognised for htaccess auth then you are entering the wrong details.

    The first two are essentially hosting issues which only your host can resolve.
    I believe Jake already told you this about your previous issue: http://xenforo.com/community/threads/acp-styles-properties-appearances.48485/#post-520709

    The last one just requires you to enter the same details you entered when setting up authentication.
     
  6. ThunderBird2

    ThunderBird2 Member

    Okay. I will contact them again.

    I checked everything, it is not there. I check error logs, at this moment I can't access to ACP due to connection issues

    I did. AuthFile path is not correct or wrong names. I am confused, please bear with me when my site will be up soon. I will ask for more help to solve this matters.
     
  7. Tracy Perry

    Tracy Perry Well-Known Member

    And you are using the correct AuthType and generated htpassword file that matches?
    If using nginx the forms config file needs to contain
    auth_basic_user_file /path_to_your_htpasswd_file/htpasswd_file_name;

    If using Apache then

    <FilesMatch "admin.php">
    AuthType Basic
    AuthName "Not for general sale"
    AuthUserFile "/path_to_your_htpasswd_file/htpasswd_file_name"
    require valid-user

    #AuthName "Control Panel"
    #AuthType Basic
    #require valid-user
    </FilesMatch>

    If on a shared hosting provider normally you have to use the full path. When I was with HostGator I had to use (where tdperry was my account name)
    /home/tdperry/public_html/path_to_file/file_name.
     
    ThunderBird2 likes this.
  8. Brogan

    Brogan XenForo Moderator Staff Member

  9. ThunderBird2

    ThunderBird2 Member

    Yes, shared hosting provider, tdperry was your hostgator cPanel username right? I will double check all over again with full path.

    Here's clear details but I don't know how come wrong for me....
    http://support.hostgator.com/articles/cpanel/how-to-password-protect-one-file

    Good practice to fix the errors and I am learning, will let you know later.

    I will bookmark this thread, I probably read this more than 50 times. The best part is I like IP based protection, it will goes back to homepage or /index.php automatically, correct? hackers or anyone will have hard time to find admin.php due to IP address block except specific of my location ?
     
  10. James

    James Well-Known Member

    They'll just receive a 403 forbidden error, it won't redirect.

    Only use it where your IP is static or else you'll be forever changing the .htaccess to your new IP.
     
    ThunderBird2 likes this.
  11. ThunderBird2

    ThunderBird2 Member

    How could the IP address itself will change if you stay in the same place, not moving from location to location?
     
  12. Tracy Perry

    Tracy Perry Well-Known Member

    Yes, tdperry was my cpanel username. I had Forgotten the /home portion in front of the username. It is a standard layout using Apache2 and userDir.
     
    ThunderBird2 likes this.
  13. Tracy Perry

    Tracy Perry Well-Known Member

    Doesn't matter if you are moving or not. The addresses are assigned from a pool and have a TTL of a set amount. Most home broadband connections are DHCP unless you pay an extra fee for static.
    This can result in your putting your CURRENT IP address in the block - but a month from now the IP may not be the same so you are buggered.
     
    ThunderBird2 likes this.
  14. ThunderBird2

    ThunderBird2 Member

    Thanks for good advices, I appreciate it.

    Yes, it work fine on my side.
     
  15. Tracy Perry

    Tracy Perry Well-Known Member

    If you put the above in your root .htaccess, then that is to be expected as you are telling it to protect ALL files in your root folder. That is why you have to do a file match for admin.php. The wildcard one you do is for the /install directory itself in case someone types in http://yourdomain.com/install
     
    ThunderBird2 likes this.
  16. ThunderBird2

    ThunderBird2 Member

    Thank you for your support.

    1) Change Administrator's color, ACP > Users > Administrators > ? or my profile page doesn't have the options available.

    2) Left column, how to find hover color during personal or contact detail pages because my site, the hovering is full of white to blank the labels. For example, see picture below, Under Conversations, it showed light blue hover color.

    ACP > Appearance > Style Properties > Message Layout or Message Elements or Member Profile Page?

    [​IMG]
     
  17. James

    James Well-Known Member

    ThunderBird2 likes this.
  18. ThunderBird2

    ThunderBird2 Member


    Thanks James. :D
     
  19. ThunderBird2

    ThunderBird2 Member

    Please how exactly I could reduce the width size of the white long space on category areas.

    [​IMG]
     
  20. Brogan

    Brogan XenForo Moderator Staff Member

    Set a fixed width for the style?
     
    ThunderBird2 and Shelley like this.

Share This Page