1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Soft 404 errors issue

Discussion in 'Server Configuration and Hosting' started by gordy, Jun 20, 2012.

  1. gordy

    gordy Well-Known Member

    Greetings all,

    I've been getting several reported "soft 404" errors from google analytics.

    On some pages that don't exist for example: http://www.planetfigure.com/wiki/index/Cold_War

    This page does not exist and I have the "ErrorDocument" directive set in .htaccess like so:

    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    Is there another way to reconcile these error messages? Maybe a page redirect within the AdminCP ?

    Thank you for any help—
  2. Chris D

    Chris D XenForo Developer Staff Member

    You could redirect the pages using mod_rewrite in htaccess but I don't think soft 404 errors are a major issue.

    I believe they eventually get removed from the index and have little to no impact on SEO.
  3. gordy

    gordy Well-Known Member

    Tried that, but the problem is there's no way to wildcard it without redirecting real pages :/

    Hmm, i'd like to think so but google is squawking about it.

    Since I have an hourly cron that scrapes my access-logs and reports them as sitemaps, I might just have that portion awked out...
  4. Chris D

    Chris D XenForo Developer Staff Member

    I see you've got your htaccess specifying the default error pages - which should be fine - but Soft 404 errors often happen when an error page is reached, but the response code is 200 (response OK).

    So I'm reading that one cause of that is when you specify a custom error with an absolute URL (http://www.yoursite.com/error.html) as opposed to specifying a custom error with a relative URL (/error.html).

    You're not redirecting to a custom error at all, but I'm just wondering what happens if you do... Maybe it's worth a try.
  5. Chris D

    Chris D XenForo Developer Staff Member

    Before that, it might be worth fetching your page as Google.

    You can do that in Google Webmaster Tools > Health > Fetch as Google.

    Fetch that page, and see what the response error is.

    The top line:

    HTTP/1.1 200 OK
    Date: Thu, 08 Mar 2012 10:55:15 GMT
    Server: Apache/2.2.14 (Ubuntu)
    Your page that isn't working should be returning 404. If it isn't then, that's what's causing the Soft 404.

    If that turns out to be the case, it may be worth setting up a custom error page (with a relative URL) and then running the Fetch as Google again. Hopefully it will then indicate the correct HTTP response code.
  6. gordy

    gordy Well-Known Member

    I decided to go with separating the apache logs with mod_log_config into an error code for each file 404's into one log file, !200's into a separate file and then all else into an access file and pointed my sitemap script to just the access file. It's rockin' now, thanks for the help!
    Yorick likes this.

Share This Page