• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 smtp.gmail.com errors

Jeffin

Well-known member
#1
I have been away from my forum for a while and when I returned I found these server errors:

smtp.gmail.com has timed out
4.7.0 Cannot authenticate due to temporary system problem. Try again later. v75sm22386255qge.6 - gsmtp
stream_socket_enable_crypto(): SSL: crypto enabling timeout
fgets(): SSL: Connection reset by peer
5.4.5 Daily sending quota exceeded. n8sm12037910qaz.18 - gsmtp
and there are lots of these similar errors. Is it because I might have reached Google Apps sending limit?

Thanks.
 

Brogan

XenForo moderator
Staff member
#2
Are you sure it is configured correctly in terms of authentication and encryption, etc?

Google recently changed the set up, I know I had to update the mail accounts in Outlook on my PC.
 

Mike

XenForo developer
Staff member
#3
The explanation is in the message:
4.7.0 Cannot authenticate due to temporary system problem. Try again later.
It's an issue on Google's side. Note that XenForo doesn't queue failed emails so emails that hit this will not be sent. (That's one of the reasons we don't recommend SMTP if avoidable.)
 

Jeffin

Well-known member
#4
The explanation is in the message:

It's an issue on Google's side. Note that XenForo doesn't queue failed emails so emails that hit this will not be sent. (That's one of the reasons we don't recommend SMTP if avoidable.)
Hi Mike, wouldn't it be good to get Xenforo to queue failed emails especially the important ones like email_confirmation?
 

SamL

Active member
#5
Instead of asking Xenforo to add SMTP client features, it would probably be better to follow their recommendations and set your server up so that you don't have to use SMTP from your forum.
Since you use Gmail, you're presumably using Google Apps for your Domain rather than a random @gmail account. If that's the case, you can just follow Google's procedures for setting it as your default MX server via DNS entries, and set your server host address as a permitted sender for your domain. Your server will simply forward MX through Google then, without needing to configure SMTP sessions at the forum level.

JMO
 

Jeffin

Well-known member
#6
Oh my goodness. I am just beginning to understand how this works. For so long, I have had my domain MX records configured with Google Apps and I have also had my forum SMTP sessions configured for Google. So you are saying to me that the second step is not required and that I have to switch Email Transport Method back to Default and the emails will still be handled by Google Apps.

ss1.jpg

ss2.jpg

Thank you very much for pointing this out to me.
 

Mike

XenForo developer
Staff member
#7
Ehh, that's not exactly right. MX records are only for mail delivery.

He was (I think) suggesting that you set your local MTA (postfix, etc) to forward emails through Google. Alternatively, you could just send your emails through your local MTA and have it send directly (what I was suggesting). If you follow best practices (reverse DNS, SPF, etc) and your IP hasn't been blacklisted, that is usually fine.
 

SamL

Active member
#8
He was (I think) suggesting that you set your local MTA (postfix, etc) to forward emails through Google. Alternatively, you could just send your emails through your local MTA and have it send directly (what I was suggesting). If you follow best practices (reverse DNS, SPF, etc) and your IP hasn't been blacklisted, that is usually fine.
Yes, that's what I was suggesting. And I agree that just sending through your local MTA would work fine too. Either one is preferable to using SMTP directly from your forum.