XF 1.5 SMF 2.0 to XF 1.5 Import snafu (99.9% sure it's gonna be my own fault)


My name is Mel, and I probably messed up by being dumb, despite having the installation & importer instructions up. So I just purchased Xenforo in excitement for my small role playing and writing community, GreaterRealms. Long story short: I wanted to give them both a forum and a chat room to write in. Xenforo has an amazing paid chatroom add on that I wish to someday purchase, but first, I needed Xenforo, and then I needed to set up a test to see how the importing from SMF > 1.5, Upgrade to 2.0 would do.

My first step of installing Xenforo went 100% smoothly. My second step of using the Importer in 1.5 went AWESOME. Not a single error or hitch.

So, what's the problem?

There are no posts in the test forum at all. The categories are there. The user groups are there. Xenforo tells me there are at least 1000 discussions. I have a member list. The avatars made it. However, if I click on my own Admin name (merged), or any member, they have no posts / no content, and no sub forums (child nodes?) can be seen outside of the main nodes.

I have a small theory that I am sort of dreading might have happened:

In SMF I am using an outdated, heavily edited Subaccounts package which allows members to create 1 account with a "main" name, and several subaccounts using the same email to their 'main' name. I am worried that this somehow is affecting posts.

I have been working in node permissions to see if that had anything to do with it, but it doesn't seem to as I cannot find posts anywhere.

I am sort of completely lost as to how to fix this and may have accidentally run the importer a second time like the giant goober I am. Now I have double categories/nodes, but still no posts.

Too long; Didn't read: How do I get my SMF posts to show up in Xenforo? Does the issue have something to do with a subaccounts mod originally on SMF? Do I need to do a clean re-install of Xenforo and how do I do that, or is there a bath delete all somewhere?

How is Xenforo formed? Many thanks for all who read and try to help.

Host: Dreamhost, unlimited, php requirements ran and all clear, php 7
SMF forum link: https://greaterrealms.us/index.php?action=forum
Xenforo Alpha test link: http://www.2phatgeeks.com/grxentest/index.php


  • GR Xenforo Alpha (1).png
    GR Xenforo Alpha (1).png
    22.4 KB · Views: 4
  • GR Xenforo Alpha.png
    GR Xenforo Alpha.png
    32.4 KB · Views: 4


XenForo moderator
Staff member
I suspect it may just be permissions.

Although the importers try to map across, it doesn't always work, so we recommend checking and setting permissions as required after importing.
You can use the permissions analyzer for a specific member account/node to determine where the final value is coming from.

What error message do you receive if you try to load a thread that should be available?
You can just use http://www.2phatgeeks.com/grxentest/index.php?threads/1 for example - change the 1 to a value for a thread which isn't visible.

For what it's worth, I see threads as a guest.

Well I feel dumb. At any rate, it tells me I do not have permission to view those threads. So heyyyy, yeah! Permissions--I thought by individually changing them in users would work. I guess not. Could you hit me over the head with the obvious-how-to-permissions link or what not?


XenForo moderator
Staff member
These links should help:

These links should help:

As soon as I typed the above response I went back and..., I realize I have been clicking the wrong thing in node permissions. It's not group info I need to click, but the actual NAME of the group in node permissions to change them individually.

@Brogan you are a saint. Thanks for being patient.
I'm not sure what's going on, but I cannot see threads even logged out?

Edited to add: My husband cannot access anything either, the website is telling him that he needs to be logged in to do that, same on my end
Last edited:
Problem #1: Instead of merging GreaterRealms from SMF to Xenforo as an admin, it has associated all my administration posts to a Subaccount from SMF. Finally just now when logging out, I can actually see all posts in each node. I am almost positive now that the SMF subaccounts have confused Xenforo. I believe I may have to wipe what I have, turn off the subaccounts mod in SMF, and then try another import.


XenForo moderator
Staff member
If the subaccounts function is from a third party add-on then the XF importer won't have any knowledge of it so will likely just create separate accounts for each one.
The way the subaccounts work on the SMF forums, is that is creates multiple accounts associates with one, where members can make many accounts with the same email. During importing, I checked the "merge multiple users with emails," and I think for some reason that is causing this odd permissions issue. When I logged out and looked at all the posts that should have been under my SMF/Xenforo admin name, GreaterRealms, it displays on the test version as A Shadows Whisper, which is not my main account on SMF, but a subaccount (if that makes sense?) , it's also using another avatar from another subaccount from mine, neither GreaterRealms or A Shadows Whisper.

I have the ability to turn off this subaccounts mod on my SMF website, so I am doing to try a fresh install after turning that off on SMF and see how Xenforo reacts.

Also, sorry @Brogan for spamming replies. I should probably learn to keep replies to a condensed single one. :p Thanks again for dealing with this panicked newbie!
All righty! Back with another (rap verse?) clean install.

This time I: Created an admin user name with the clean install different from the SMF forum name, Pinkatron2000.

I turned off subaccounts on the original SMF and began import.

Same thing happened as before: Pinkatron2000 could not see any posts logged in, even with permissions set to allow all. So I logged out, and voila, as a guest, I can see all posts and categories. I logged in to my Imported SMF admin, and I can also see all posts. However, the name GreaterRealms is not an admin.

I am not entirely sure where the permissions are that I am somehow messing up, but now I also have an error.

XenForo_Exception: Step users cannot be run. - library/XenForo/Importer/Abstract.php:120
Generated By: Pinkatron2000, 18 minutes ago

#0 /home/bariguy/2phatgeeks.com/grxentest/library/XenForo/ControllerAdmin/Import.php(189): XenForo_Importer_Abstract->runStep(Object(XenForo_ControllerAdmin_Import), Object(XenForo_ImportSession), 'users', 0, Array)
#1 /home/bariguy/2phatgeeks.com/grxentest/library/XenForo/ControllerAdmin/Import.php(241): XenForo_ControllerAdmin_Import->_runStep(Object(XenForo_Importer_SMF), Object(XenForo_ImportSession), 'users', 0, Array)
#2 /home/bariguy/2phatgeeks.com/grxentest/library/XenForo/ControllerAdmin/Import.php(184): XenForo_ControllerAdmin_Import->_startStep(Object(XenForo_Importer_SMF), Object(XenForo_ImportSession), 'users', Array)
#3 /home/bariguy/2phatgeeks.com/grxentest/library/XenForo/FrontController.php(369): XenForo_ControllerAdmin_Import->actionStartStep()
#4 /home/bariguy/2phatgeeks.com/grxentest/library/XenForo/FrontController.php(152): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#5 /home/bariguy/2phatgeeks.com/grxentest/admin.php(13): XenForo_FrontController->run()
#6 {main}

array(3) {
["url"] => string(63) "http://www.2phatgeeks.com/grxentest/admin.php?import/start-step"
["_GET"] => array(1) {
["import/start-step"] => string(0) ""
["_POST"] => array(3) {
["options"] => array(2) {
["mergeEmail"] => string(1) "1"
["_dummy"] => string(1) "1"
["step"] => string(5) "users"
["_xfToken"] => string(8) "****"


Active member
I had the same issue, it was a permissions issue with the conversion.

Basically, my administrator user permissions were screwed up and did not allow me to see posts except in one forum. The others are there, you just aren't allowed to view them. I basically allowed everything for my account, after which I could see forums and posts fine. Sadly, as well as fixing my specific user account permissions, I discovered that each of my 60 forums had specific permissions assigned to each of my 16 user groups, with a fairly random selection of settings per group.

I fixed this by editing the database directly in mySQL;

use xenforo_secretprojects;
DELETE FROM 'xf_permission_entry_content' WHERE 'xf_permission_entry_content'.'content_id' = x;
(don't try this unless you know what you are doing!)

Where x is the node number of each forum.

This returns each board to 'inherit permissions', discarding all board specific settings (198 per forum in my case!).

I've then redone the permissions using private nodes and editing the user and group permissions.

Incidentally the root cause is probably that the SMF Administrator account has ONLY specific admin type permissions set, and relies on receiving normal user permissions from being in a member group of some kind. The permissions combine in SMF but after migration, not. guests will probably be OK. The SMF converter should add default user permissions to the Administrator account to account for this.
Last edited:


Well-known member
Yes, back when I migrated away from SMF I had the same issue with invisible forums. The individual forum permissions imported into XenForo pretty randomly without any obvious pattern. I ran a similar SQL query to what @Overscan wrote above to reset these node permissions after the import was complete. With a backup at hand in case something went awry, this fixed the issues of missing forums when logged in. I found it much simpler to configure node permissions from a clean slate anyway.

Just be mindful that any previously secret forums would become viewable until you set the "Private node" checkbox for each affected forum in the Node permissions. If this is an issue, perhaps temporary close your forum while you make the changes (Options -> Board Active).
I am going slowly batty. I had to do another uninstall because I am, frankly, an idiot.

So I upped Xen 1 to import SMF database...and again, the new admin GR Admin cannot see any posts. Permissions are set. Name is super admin. Config has 'superadmins'='1'; in both files. So I add my OLD SMF Admin name, GreaterRealms in Xen 1 to administrator, then make them a super admin, then add '2' , their member number to config. That account cannot see any posts logged in at all.

So I try and CREATE a user. Pinkatron2000, I set that up and edit config.

Nope. Can't see anything either.

The test install I did on an alpha site worked when I created a new user and made them super admin from the first admin account after transfer. I thought it would work here, too. It isn't. I have no idea how to run the above suggestion to reset everything as although my php account user has all access, it keeps saying "access denied," to xenforo_secret projects.

I am really at the end of my rope on what to do.

EDIT: Re-re-re-installation number 3. It is going well so far.
I have no idea why it's working now but I am knocking on wood (and my own head) for luck.
Last edited: