1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Size of Avatar

Discussion in 'Troubleshooting and Problems' started by Ark Royal, Dec 3, 2013.

  1. Ark Royal

    Ark Royal Active Member

    Possibly since upgrading to 1.2.3 I have noticed that my Avatar looks different depending where I look at it, see below.

    Capture.JPG

    Capture1.JPG
    Previously it was always the same image, rather than a zoomed version. Is it possible I have changed a setting somwehere? If so how do I change it back?

    Many Thanks
    AR
     
  2. Amaury

    Amaury Well-Known Member

    Avatars aren't re-sized on profiles.
     
    Last edited: Dec 3, 2013
  3. Ark Royal

    Ark Royal Active Member

    Not sure how your comment helps Amaury? You can see from the images I have posted that I appear to have 3 different avatars depending on where they are used rather than the same avatar in 3 different sizes.
     
  4. Ark Royal

    Ark Royal Active Member

    But.....
    If I change to this image, things look ok?

    Capture.JPG
    Both images are jpg's the first is 223x256 the second is 225x255 why is there a difference?
     
  5. Amaury

    Amaury Well-Known Member

    Because avatars aren't the same size everywhere.
     
  6. Ark Royal

    Ark Royal Active Member

    I know that but in one example they are the same image, whilst being different sizes in the other example they are different areas. Look at the images in my post.
     
  7. Amaury

    Amaury Well-Known Member

    They get cropped by XenForo.
     
  8. digitalpoint

    digitalpoint Well-Known Member

    Was the original avatar imported from another system by chance?
     
  9. Mike

    Mike XenForo Developer Staff Member

    @Amaury - you really need to watch out. You're giving out incorrect information. Avatars are always resized, though they will be cropped to square for certain sizes. You can see that based on his second example.

    The upgrade wouldn't have changed the avatar. If it's working with a new avatar, it must have been a problem before. We have had some reports of cropping not working with imagick in certain scenarios, but it may be well be version specific (as in, the version of the PECL extension or the version of ImageMagick it's built against). However, you should be able to reproduce this so I would check the original image again.
     
  10. Amaury

    Amaury Well-Known Member

    Roger that.

    I actually missed the "upgraded" part, so that was indeed my bad. Please accept my apologies. I thought he was talking about something like this appearing different everywhere else, such as the member card.
     
  11. Ark Royal

    Ark Royal Active Member

    @Mike it appears to be inconsistent behaviour depending on the image being used for the avatar.
    The 'Aladin Zane' image behaves as I expect but the 'Diamond Dogs' image does not.

    Neither image has been imported from another system. I will try using them on here and see if they behave differently.
     
  12. Ark Royal

    Ark Royal Active Member

    It works on here but not on my forum?

    Capture.JPG

    Very strange, any ideas?
     
  13. Mike

    Mike XenForo Developer Staff Member

    Can you confirm if the Diamond Dogs image still doesn't work if you upload it?

    Can you confirm if you're using Imagick or GD for image processing?
     
  14. Ark Royal

    Ark Royal Active Member

    Diamond Dogs not work when re-uploaded.
    I am using Imagick
     
  15. Mike

    Mike XenForo Developer Staff Member

    Can you attach the original here please?
     
  16. Ark Royal

    Ark Royal Active Member

    Will do this evening.
     
  17. Ark Royal

    Ark Royal Active Member

    bowie.jpg
    @Mike Please find file as requested.
     
  18. Mike

    Mike XenForo Developer Staff Member

    Amaury likes this.
  19. russoroni

    russoroni Active Member

    Can anyone tell me if theres a setting somewhere or a file edit that would fix the avatar in the member card from cropping incorrectly? I made some changes the other day to change the L avatars from 192px to 222px and everything looks good except the member card.

    ScreenHunter_20 Dec. 21 18.54.jpg

    heres what the L avatar looks like in the member profile...

    ScreenHunter_21 Dec. 21 19.03.jpg
     

Share This Page