1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Site error

Discussion in 'Troubleshooting and Problems' started by Nelson T., Feb 26, 2015.

  1. Nelson T.

    Nelson T. Guest

    Forbidden
    You don't have permission to access / on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

    I changed permissions of the data and internal data folders to 777 and the rest to 755 and got this error on www.hobby-machinist.com

    Possible causes?
     
  2. ruaduck

    ruaduck Member

    It can be an issue in your PHP.ini file. So make sure that PHP is enabled on your server to run and that you are running the most current PHP.ini file to what PHP is installed on your server.
     
  3. Nelson T.

    Nelson T. Guest

    P h p is good. Site was up. I changed permissions and bang, this happened.
     
  4. ruaduck

    ruaduck Member

    If you change back to 777 it no longer has the error?
     
  5. Liam W

    Liam W Well-Known Member

    This is a server issue - apache does not have the ability to read the index.php file, or has to much ability (I believe some PHP handlers throw a 403 if the permissions are too allowing).

    Liam
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    Was it working before? Who owns those files/folders (user or the HTTP user)?
    Do NOT change them all to 777. That is a security risk. At the most, 775 (for user:group) can be set.
     
  7. Nelson T.

    Nelson T. Guest

    I had the root permissions at 755 instead of 711, which killed access.

    I had the data, internal data and mobiquo directories at 777, but I don't know what the correct permissions are for the remainder of the directories, so everything is screwed up.

    You can't even post a message, the message box does not show up (I assume it is a graphic)...
     
  8. Tracy Perry

    Tracy Perry Well-Known Member

    Using suPHP I assume on the Apache setup?

    if you are using cPanel, set up another site and see what those perms are set at.
     
  9. Nelson T.

    Nelson T. Guest

    If you don't set certain directories to 755, you don't get all the graphics. Sad none of the mods helped me on this. They let me flounder with my site down.
     
  10. Tracy Perry

    Tracy Perry Well-Known Member

    I don't think it's really the mod/dev position to help with the HTTP server problem. That is more in line with your hosting provider and not really a question for the script support.
     
  11. Chris D

    Chris D XenForo Developer Staff Member

    As you've been told before, the only place you would be guaranteed a response from a staff member is by submitting a ticket to us from your customer area.
     
    Amaury likes this.
  12. Brogan

    Brogan XenForo Moderator Staff Member

    And for the record, I did provide some support, during working hours.
     
    Amaury likes this.
  13. Nelson T.

    Nelson T. Guest

    Setting the permissions up to 755 wasn't a server issue. It is an issue in XenForo. Some directories have to be set to 755 or higher, or you will not see the graphics.
    I contacted the web host, and they corrected the permissions to the extent that they exceeded 711 in the ROOT area, that was the server issue. My web host resolved it in minutes.
    My server can have any permissions in the public_html area BUT if you go too low on CERTAIN XenForo folders, you won't see your graphics, which includes the post graphic and some javascript functionality.
    Try setting the last 3 folders in your XF installation to 751, and you will see what happens. Be sure to set them back.

    My site was down 2 days because no one told me this.
    I have opened tickets before. Got the same terse answer that I didn't understand.
    I am being factual, not personal or overly critical.
     
  14. Mike

    Mike XenForo Developer Staff Member

    Just to confirm, any JS files and graphics that are part of XenForo are not served by XenForo in any way. They are served by the web server directly. There are permissions that your web server will require for things to run and the specific values will vary depending on how it's configured. That's why your host is usually best positioned to answer or help when it comes to permission questions. This is doubly true when it's on a file that's unrelated to XenForo.

    If you're example of setting a folder to 0751 (or 0711), if the webserver is running as "nobody", "nginx", etc and the files are owned by someone else, I would totally expect a permission error; you've explicitly set the file to not be world readable. Then again, maybe your host has added the webserver user to the group that owns the files you FTP'd up and 0751 would be ok. This isn't something that we would be able to know or have access to.

    On a side note, I really wouldn't change permissions on files/directories unless you know why you're doing it. If you're FTPing files, the permissions that are being set are what your host determined to be reasonable defaults.
     
    ruaduck and Liam W like this.
  15. Tracy Perry

    Tracy Perry Well-Known Member

    The server permissions that are set are controlled by YOUR host.
    For me, I don't require 711 to be set anywhere. It's specific to your install that is configured and controlled by your host.
    There are so many variances that you cannot expect that they can solve all of them. What you need is that the /data and /internal_data have read/write permissions by your HTTP server (and PHP processor).

    Who told you to set them at 751? It's pretty much well known that if you remove the "read by others" then the HTTP server can have issues - especially if your HTTP server and PHP processor run as separate users and the directory is owned by a third user. This is very typical under a cPanel/WHM/Apache setup.


    Don't know what "terse" answer you got, but it can't get any plainer than the /internal_data and /data need to be writeable by the HTTP server and PHP processor - and if they don't run as the same user:group then you have to have 777 perms set.
    If you didn't understand the answer then you needed to request clarification or if the answer was technical in nature and if above your ability to understand refer it to your hosting provider.
     
    ruaduck and Liam W like this.
  16. Nelson T.

    Nelson T. Guest

    Funny how some people are quick to jump on you, but never speak up when you need help.
     
  17. Tracy Perry

    Tracy Perry Well-Known Member

    Maybe because not everybody reads every thread in every one of the forums here. I infrequently check in this area... but if you had of posted this in the server discussion area (where I and some of the more server literate people hang out) you would have been more apt to get a response... since this WAS a server issue.
    Once you started fiddling with the permissions of any directory besides the /data and /internal_data you then stepped into the realm of perms and what the PHP processors and HTTP servers want/need. That's why it's generally not recommended that you mess with that if you don't know what you are doing.
     

Share This Page