• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 sidebar_online_users "Staff online"

#1
Hey guys,
my problem is the sidebar (sidebar_online_users) "staff online" isn't working correctly for me, I'm new to XenForo and it's templates....

Have a look:


<div class="section staffOnline avatarList">
<div class="secondaryContent">
<h3 class="heading"><i class="fa fa-users"></i> {xen:phrase staff_online_now}</h3>
<ul>
<xen:foreach loop="$onlineUsers.records" value="$user">
<xen:if is="{$user.is_staff}">
<li>
<xen:avatar user="$user" size="s" img="true" />
<xen:username user="$user" rich="true" />
<div class="userTitle">{xen:helper userTitle, $user}</div>
</li>
</xen:if>
</xen:foreach>
</ul>
</div>


<!-- block: sidebar_online_staff -->
<xen:if hascontent="true">
<div class="section staffOnline avatarList">
<div class="secondaryContent">
<h3 class="heading">
<i class="fa fa-users"></i>
<a href="{xen:link members, '', 'type=staff'}">{xen:phrase staff_online_now}</a></h3>
<ul>
<xen:contentcheck>

<xen:foreach loop="$onlineUsers.records" value="$user">
<xen:if is="{$user.is_staff}">
<li>
<xen:avatar user="$user" size="s" img="true" />
<xen:username user="$user" rich="true" />
<div class="userTitle">{xen:helper userTitle, $user}</div>
</li>
</xen:if>
</xen:foreach>
</xen:contentcheck>
</ul>
</div>
</div>
</xen:if>
<!-- end block: sidebar_online_staff -->

I hope anyone can help me :/.

Yours,
Montimedici
 

Brogan

XenForo moderator
Staff member
#2
Does it work in a default style with add-ons disabled?

If so, you will need to narrow it down to an add-on or style issue by enabling them one at a time.