1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Should I delete Install directory?

Discussion in 'XenForo Questions and Support' started by Shyuan, Jul 30, 2012.

  1. Shyuan

    Shyuan Well-Known Member

    Hi All,

    I thought I should delete the install directory, and so I deleted it even there's no instruction mentioning it. Until today I did a File Health Check, it told me all the potential problems involved were all "File not found." specifically for the Install directory that was deleted by me.

    Should I reupload the Install directory using the XF .zip file that can be downloaded in my client area? Thanks. :)
     
  2. MagnusB

    MagnusB Well-Known Member

    Yes, you should. The directory is protected in some manner I can't recall ATM.
     
  3. Shyuan

    Shyuan Well-Known Member

    Oh no, my bad :( XF is so special.
     
  4. MagnusB

    MagnusB Well-Known Member

    It is different, not always in a bad way. Though it takes some getting used too.
     
  5. Shyuan

    Shyuan Well-Known Member

    And that is why I love XF :D

    Anyone if you know how exactly the Install directory should be placed back into my forum root, please let me know! Thanks!
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Upload the original install directory from the zip file. Nothing special.

    The install script is locked out by the creation of the internal_data/install-lock.php file when you run the install.
     
  7. Shyuan

    Shyuan Well-Known Member

    So if I upload the install directory now, it will automatically be locked again? Since my forum installation was done few weeks ago. Thanks :)
     
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  9. Shyuan

    Shyuan Well-Known Member

    Thanks, Jake :)
     

Share This Page