1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Design Issue Setting node to private is seriously slow

Discussion in 'Resolved Bug Reports' started by SchmitzIT, May 15, 2011.

  1. SchmitzIT

    SchmitzIT Well-Known Member

    We're in the middle of our upgrade and noticed permissions went all boinkers. So we're currently manually fixing stuff, and as a protection measure setting all private forums explicitly to be private. However, this is taking forever, and we cannot figure out why?

    It reminds me of the old "deleting a user group" bug I filed before, which also took substantially long, and at times would plain time out.

    We have a large number of forums and groups, but still. There's no reason a simple update like this ought to take 30 seconds.

    Oh, and pretty please, can we get a "inherit all user groups" button per node permission?
     
  2. Mike

    Mike XenForo Developer Staff Member

    It's actually not a simple operation at all - it causes a large number of caches to have to be rebuilt (though possibly not quite all of them :)). Its speed is dependent on the number of "permission combinations" and nodes you have. Unfortunately, only so much can be done to speed it up as 1 change can affect hundreds or thousands of elements.
     
  3. SchmitzIT

    SchmitzIT Well-Known Member

    Mike,

    That makes sense. In that case, perpahs increase (or somehow make it admin-configurable) the timeout limit for such operations?

    Thanks :)

    Peter
     
  4. James

    James Well-Known Member

    Isn't there a way to prioritise and make the update periodic? Such as the main priority to change viewing permissions, then reading, then writing? This could be done over a time period of a couple of minutes, making the most obvious permissions (viewing/reading/replying) priority.
     
  5. Digital Doctor

    Digital Doctor Well-Known Member

    I made a forum private.
    But it isn't taking effect.
    Is it possible I have all the settings correct ... but it's just taking time ?
    What are the expected and "maximum" times I should wait ?
     

Share This Page