1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Server error log: Undefined index: node_id

Discussion in 'Troubleshooting and Problems' started by lwn, Sep 21, 2014.

  1. lwn

    lwn Member

    Since upgrading from 1.3 to 1.4 last friday I have a lot of these errors in the logfiles:

    Code:
    Info over Fout
    ErrorException: Undefined index: node_id - library/InfisJSC/TopicStarter/Model/Thread.php:126
    Gegenereerd Door: Hybrid, 7 minuten geleden
    Stack Trace
    #0 /var/www/forum.xboxworld.nl/htdocs40/library/InfisJSC/TopicStarter/Model/Thread.php(126): XenForo_Application::handlePhpError(8, 'Undefined index...', '/var/www/forum....', 126, Array)
    #1 /var/www/forum.xboxworld.nl/htdocs40/library/InfisJSC/TopicStarter/Model/Thread.php(121): InfisJSC_TopicStarter_Model_Thread->_checkPermission(true, NULL, Array, NULL, 'tsRighTeditPoll')
    #2 /var/www/forum.xboxworld.nl/htdocs40/library/XenForo/ControllerPublic/Thread.php(150): InfisJSC_TopicStarter_Model_Thread->canEditPoll(Array, Array, Array)
    #3 /var/www/forum.xboxworld.nl/htdocs40/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Thread->actionIndex()
    #4 /var/www/forum.xboxworld.nl/htdocs40/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #5 /var/www/forum.xboxworld.nl/htdocs40/index.php(13): XenForo_FrontController->run()
    #6 {main}
    Aanvraagstatus
    array(3) {
      ["url"] => string(57) "http://forum.xboxworld.nl/threads/destiny.168886/page-274"
      ["_GET"] => array(1) {
        ["/threads/destiny_168886/page-274"] => string(0) ""
      }
      ["_POST"] => array(0) {
      }
    }
    Code:
    ErrorException: Undefined index: user_id - library/InfisJSC/TopicStarter/Model/Thread.php:127
    Gegenereerd Door: Onbekend Account, 9 minuten geleden
    Stack Trace
    #0 /var/www/forum.xboxworld.nl/htdocs40/library/InfisJSC/TopicStarter/Model/Thread.php(127): XenForo_Application::handlePhpError(8, 'Undefined index...', '/var/www/forum....', 127, Array)
    #1 /var/www/forum.xboxworld.nl/htdocs40/library/InfisJSC/TopicStarter/Model/Thread.php(121): InfisJSC_TopicStarter_Model_Thread->_checkPermission(false, NULL, Array, NULL, 'tsRighTeditPoll')
    #2 /var/www/forum.xboxworld.nl/htdocs40/library/XenForo/ControllerPublic/Thread.php(150): InfisJSC_TopicStarter_Model_Thread->canEditPoll(Array, Array, Array)
    #3 /var/www/forum.xboxworld.nl/htdocs40/library/XenForo/FrontController.php(347): XenForo_ControllerPublic_Thread->actionIndex()
    #4 /var/www/forum.xboxworld.nl/htdocs40/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #5 /var/www/forum.xboxworld.nl/htdocs40/index.php(13): XenForo_FrontController->run()
    #6 {main}
    Aanvraagstatus
    array(3) {
      ["url"] => string(57) "http://forum.xboxworld.nl/threads/destiny.168886/page-274"
      ["_GET"] => array(1) {
        ["/threads/destiny_168886/page-274"] => string(0) ""
      }
      ["_POST"] => array(0) {
      }
    }
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    The Infis Topic Starter add on seems to be referenced in the error. Please disable that add on and try again and report the issue in the thread for that add on.
     
  3. borbole

    borbole Well-Known Member

    They seem to be caused by a Topic Starter sort of mod. It would be best to post at that add on 's thread about this. So its coder can look into it.
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    Why didn't I think of that?
     
  5. lwn

    lwn Member

    Thanks! Times two ;)
     
    Chris D likes this.
  6. lwn

    lwn Member

Share This Page