1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server Error Log: Read timed out after 10 seconds

Discussion in 'Troubleshooting and Problems' started by Dmitriy, Sep 6, 2013.

  1. Dmitriy

    Dmitriy Member


    look at

    for what reason this error occurs?

    appeared doubtful visitors
  2. Mike

    Mike XenForo Developer Staff Member

    It was a connection error to ReCaptcha. If it doesn't happen constantly, then it's probably just an indication that ReCaptcha was down.
    Dmitriy likes this.
  3. longanh

    longanh Member

    Error : Read timed out after 10 seconds

    I need increase time out 20s . how can i do ? @Mike

    more error : Zend_Http_Client_Adapter_Exception: Read timed out after 10 seconds - library/Zend/Http/Client/Adapter/Socket.php:512
  4. Mike

    Mike XenForo Developer Staff Member

    You would likely need to modify the code, but in general, if it times out after 10 seconds, it's more than likely going to time out after 20.
  5. longanh

    longanh Member

    i need 60 second . what is file name i can edit it ?
  6. RoldanLT

    RoldanLT Well-Known Member

    Yeah which file to edit?
  7. Brogan

    Brogan XenForo Moderator Staff Member

  8. RoldanLT

    RoldanLT Well-Known Member

    and the file got:
    Is this value in milliseconds?
    So it's only 1 second :/.
  9. RoldanLT

    RoldanLT Well-Known Member

    @Mike please.
  10. Chris D

    Chris D XenForo Developer Staff Member

    The default config is in library/Zend/Http/Client.php

    Check line 114.

    The default is 10 seconds.

    If the issue is happening on a constant or regular basis, the solution is definitely not to increase the timeout. You should be troubleshooting with your host why that would be reaching even close to 10 seconds.
    RoldanLT likes this.
  11. RoldanLT

    RoldanLT Well-Known Member

  12. Chris D

    Chris D XenForo Developer Staff Member

    Changing it in the core code probably isn't a good idea.

    Changing it in the add-on code might be more reasonable - the developer should help you with that. At some point, the add-on will be calling our Http helper or the Zend_Http_Client class - you can specify a timeout in the options array which is passed into that. Doing that would then only affect it for that one thing rather than doing it for everything by default.
    RoldanLT likes this.

Share This Page