1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 server error and domain not redirecting w/o www.

Discussion in 'Installation, Upgrade, and Import Support' started by Market1234, Mar 16, 2015.

  1. Market1234

    Market1234 Member

    The following error occurred:
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at webmaster@clubcensus.com to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    That sounds like a misconfiguration issue on the server somewhere.

    You can check the server error log to see what the exact cause is.
     
  3. Market1234

    Market1234 Member

    Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Unknown column 'forum.node_id' in 'where clause' - library/Zend/Db/Statement/Mysqli.php:77
    Generated By: Unknown Account, A moment ago
    Stack Trace
    #0 /home/clubcensus/public_html/library/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('\n\t\t\tSELECT foru...')
    #1 /home/clubcensus/public_html/library/Zend/Db/Adapter/Mysqli.php(381): Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), '\n\t\t\tSELECT foru...')
    #2 /home/clubcensus/public_html/library/Zend/Db/Adapter/Abstract.php(478): Zend_Db_Adapter_Mysqli->prepare('\n\t\t\tSELECT foru...')
    #3 /home/clubcensus/public_html/library/XenForo/Model.php(219): Zend_Db_Adapter_Abstract->query('\n\t\t\tSELECT foru...', Array, 2)
    #4 /home/clubcensus/public_html/library/XenForo/Model/Forum.php(133): XenForo_Model->fetchAllKeyed('\n\t\t\tSELECT foru...', 'node_id')
    #5 /home/clubcensus/public_html/library/XenForo/NodeHandler/Forum.php(85): XenForo_Model_Forum->getExtraForumDataForNodes(Array, Array)
    #6 /home/clubcensus/public_html/library/XenForo/Model/Node.php(571): XenForo_NodeHandler_Forum->getExtraDataForNodes(Array)
    #7 /home/clubcensus/public_html/library/XenForo/Model/Node.php(825): XenForo_Model_Node->mergeExtraNodeDataIntoNodeList(Array, Array)
    #8 /home/clubcensus/public_html/library/XenForo/Model/Counters.php(16): XenForo_Model_Node->getNodeTotalItemCounts()
    #9 /home/clubcensus/public_html/library/Waindigo/InstallUpgrade/Extend/XenForo/Model/Counters.php(12): XenForo_Model_Counters->getBoardTotalsCounter()
    #10 /home/clubcensus/public_html/library/XenForo/Model/Counters.php(37): Waindigo_InstallUpgrade_Extend_XenForo_Model_Counters->getBoardTotalsCounter()
    #11 /home/clubcensus/public_html/library/XenForo/CronEntry/Counters.php(15): XenForo_Model_Counters->rebuildBoardTotalsCounter()
    #12 [internal function]: XenForo_CronEntry_Counters::rebuildBoardTotals(Array)
    #13 /home/clubcensus/public_html/library/XenForo/Model/Cron.php(357): call_user_func(Array, Array)
    #14 /home/clubcensus/public_html/library/XenForo/Deferred/Cron.php(24): XenForo_Model_Cron->runEntry(Array)
    #15 /home/clubcensus/public_html/library/XenForo/Model/Deferred.php(294): XenForo_Deferred_Cron->execute(Array, Array, 4.99999809265, '')
    #16 /home/clubcensus/public_html/library/XenForo/Model/Deferred.php(428): XenForo_Model_Deferred->runDeferred(Array, 4.99999809265, '', false)
    #17 /home/clubcensus/public_html/library/XenForo/Model/Deferred.php(373): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #18 /home/clubcensus/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
    #19 {main}
    Request State
    array(3) {
    ["url"] => string(34) "http://clubcensus.com/deferred.php"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(3) {
    ["_xfRequestUri"] => string(1) "/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
    }
    }
     
  4. Market1234

    Market1234 Member

    now i am looping at the login and unable to go to the admin panel through the login
     
  5. Mr. Goodie2Shoes

    Mr. Goodie2Shoes Well-Known Member

    Post your .htaccess here :)
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Can you run this query in phpMyAdmin and paste the full text output?
    Code:
    show create table xf_forum;
    It's possible an add-on is at play.
     
  7. Mr. Goodie2Shoes

    Mr. Goodie2Shoes Well-Known Member

    I see this database error:
    Code:
    Access denied for user '???'@'localhost' to database 'ftp.clubcensus.com'
    
    That's not a database name... :/
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    Sounds like the library/config.php file has been edited incorrectly.
     
  9. Market1234

    Market1234 Member

    SQL result
    Host: localhost
    Database: ftpg
    Generation Time: Mar 16, 2015 at 11:36 AM
    Generated by: phpMyAdmin 4.0.10.7 / MySQL 5.5.41-cll-lve
    SQL query: show create table xf_forum;
    Rows: 1

    Table Create Table
    xf_forum CREATE TABLE `xf_forum` (
    `discussion_count` int...
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    If that is the first column in the xf_forum table then there is a definite problem there as the node_id column is missing.

    You will need to restore from a viable backup and then determine how it was deleted.

    Most likely it is due to an add-on.
     
    Market1234 likes this.
  11. Market1234

    Market1234 Member

    Mysqli prepare error: Unknown column 'forum.node_id' in 'where clause'

    1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    4. Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
    5. XenForo_Model->fetchAllKeyed() in XenForo/Model/Forum.php at line 133
    6. XenForo_Model_Forum->getExtraForumDataForNodes() in XenForo/NodeHandler/Forum.php at line 85
    7. XenForo_NodeHandler_Forum->getExtraDataForNodes() in XenForo/Model/Node.php at line 571
    8. XenForo_Model_Node->mergeExtraNodeDataIntoNodeList() in XenForo/Model/Node.php at line 773
    9. XenForo_Model_Node->getNodeListDisplayData() in XenForo/Model/Node.php at line 745
    10. XenForo_Model_Node->getNodeDataForListDisplay() in Audentio/UIX/Model/Node.php at line 6
    11. Audentio_UIX_Model_Node->getNodeDataForListDisplay() in XenForo/ControllerPublic/Forum.php at line 81
    12. XenForo_ControllerPublic_Forum->actionIndex() in *******/TopXStatsUsers/ControllerPublic/Forum.php at line 7
    13. *******_TopXStatsUsers_ControllerPublic_Forum->actionIndex() in WidgetFramework/XenForo/ControllerPublic/Forum.php at line 13
    14. WidgetFramework_XenForo_ControllerPublic_Forum->actionIndex() in Andy/SidebarNotices/ControllerPublic/Forum.php at line 13
    15. Andy_SidebarNotices_ControllerPublic_Forum->actionIndex() in NFLJ/Showcase/ControllerPublic/Forum.php at line 7
    16. NFLJ_Showcase_ControllerPublic_Forum->actionIndex() in XenForo/FrontController.php at line 347
    17. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    18. XenForo_FrontController->run() in /home/clubcensus/public_html/index.php at line 13
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    It's the same error.

    The column is still missing.
     
  13. Market1234

    Market1234 Member

    im getting a blank page and there is no index.html file in root which is causing this. What else could it be?
     

Share This Page