1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Internal Server Error

Discussion in 'Installation, Upgrade, and Import Support' started by aiman.h.kallaf, Oct 11, 2013.

  1. aiman.h.kallaf

    aiman.h.kallaf Active Member

    i just moved to a vps host and i can't access the forum i get this message ,

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@english4me.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    -------------------------------------
    when i removed the htaccess file it worked , so where is the problem and what should i do ,

    i have root access , is there any changes i should make ? where from ?

    thanks
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    If removing the .htaccess worked; you most likely have a misconfigured .htaccess.
     
  3. aiman.h.kallaf

    aiman.h.kallaf Active Member

    but i did not even touch or changed anything in the htaccess file , it was working fine , the problem is now when i moved to different host ( vps )

    this is the content of the file

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteCond %{HTTP_HOST} !^english4me\.net$
        RewriteRule ^(.*)$ http://english4me.net/Forum/$1 [R=301,L]
       
       
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
    
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>Options -Indexes
    Options -Indexes
    
     
  4. aiman.h.kallaf

    aiman.h.kallaf Active Member

    i have also run a check on the requirements


    Requirements Met
    Your server meets all of XenForo's PHP requirements.

    XenForo also requires MySQL 5.0 or newer. Please manually check that you meet this requirement.
     
  5. aiman.h.kallaf

    aiman.h.kallaf Active Member

    could this be a cause
    [Fri Oct 11 07:33:55 2013] [alert] [client 66.249.78.198] /..../public_html/Forum/.htaccess: </IfModule>Options without matching <IfModule>Options section
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    Don't play with .htaccess much anymore (since I use nginx), but would the duplicated highlighted segment of your example cause a problem?

    </IfModule>Options -Indexes
    Options -Indexes
     

Share This Page