• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 SEO friendly URL's !

#1
Hello guys, on my forum I want to have seo urls enabled and get rid of the index.php.. I have read this http://xenforo.com/help/friendly-urls/ but it I get a error everytime I select it.

I can access mysite.com fine but as soon as I click on any post etc it gives me an error page once I have selected SEO friendly urls.

In my htaccess file I have uncommented the RewriteBase / and added in my site installation directory. Which I have tried a number of combinations. such as /_sites/irish or /irish as that is where the install is.
I am running an apache server..

What am I missing? Cheers! :D
 

Chris D

XenForo developer
Staff member
#2
What is the error that you get when you try to enable them?

It's possible that your server doesn't have mod_rewrite enabled in which case you'd need to speak to your host or server person to have that rectified.

Also, it's worth noting that XenForo ships with a file called htacess.txt. Typically whenever I've enabled friendly URLs it's as simple as turning it on in the Admin CP and renaming that file to .htaccess. The default .htaccess file usually works without customisation.
 
#3
What is the error that you get when you try to enable them?

It's possible that your server doesn't have mod_rewrite enabled in which case you'd need to speak to your host or server person to have that rectified.

Also, it's worth noting that XenForo ships with a file called htacess.txt. Typically whenever I've enabled friendly URLs it's as simple as turning it on in the Admin CP and renaming that file to .htaccess. The default .htaccess file usually works without customisation.
Cheers its 500 Server error I am getting. My host is Godaddy so id presume they have mod_rewrite enabled?

What if I delete .htaccess turn on SEO friendlies than rename the htacess.txt?
 

Chris D

XenForo developer
Staff member
#4
GoDaddy would be able to clarify what is causing the 500 server error by looking at the Apache logs. I wouldn't presume anything with GoDaddy :)

Try it with the stock htaccess file by renaming the .txt file. If it doesn't make any difference I think GoDaddy might have to give you some help.
 
#5
GoDaddy would be able to clarify what is causing the 500 server error by looking at the Apache logs. I wouldn't presume anything with GoDaddy :)

Try it with the stock htaccess file by renaming the .txt file. If it doesn't make any difference I think GoDaddy might have to give you some help.
Woo just googled enabling mod_rewrite with godaddy pasted it in and bam it works :)