1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SEO Friendly URL's not working

Discussion in 'Troubleshooting and Problems' started by bhuwan, Feb 14, 2011.

  1. bhuwan

    bhuwan Member

    "404 Not Found" is the error I am getting.

    I just installed a xenForo to /community (not within root) of my website.
    I then logged in and enabled SEO Friendly URL's. I moved htaccess.txt to ".htaccess"

    I went to the URL of my site and attempted to visit the default installed "Main Forum" (<site>/community/forums/main-forum.2/) and I get a 404 Error


    1) I know that mod_rewrite is enabled for sure,
    2) I tried uncommenting "RewriteBase" and changing the path (no changes),
    3) Looking at the logs I see this error:
    [Mon Feb 14 09:55:20 2011] [error] [client 96.237.159.160] File does not exist: <path>public_html/community/forums, referer: http://<IP>/community/
    maybe the "/forums" is an issue?
    4) Can't think of anything else to try - open to suggestions :)

    Any help at all would be greatly appreciated ;-)A
     
  2. Mike

    Mike XenForo Developer Staff Member

  3. bhuwan

    bhuwan Member

    Mike: thanks for the reply. I just checked the Apache conf and "AllowOverride" is set to ALL.
     
  4. bhuwan

    bhuwan Member

    Mike:
    Thanks for your help. I misread the httpd.conf due to all the comments. It turns out that AllowOverride was not actually enabled. I just enabled it and everything appears tob e WORKING good. Thanks again
     

Share This Page